CVE-2025-64750 Singluarity ineffectively applies of selinux / apparmor LSM process labels

Medium 4.5 Published Updated

Attackers can bypass SELinux/AppArmor restrictions by redirecting LSM label writes via malicious container mounts, requiring specific host configurations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-64750?

CVE-2025-64750 is a medium-severity vulnerability in sylabs singularity, published on 2 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

SingularityCE and SingularityPRO are open source container platforms. Prior to SingularityCE 4.3.5 and SingularityPRO 4.1.11 and 4.3.5, if a user relies on LSM restrictions to prevent malicious operations then, under certain circumstances, an attacker can redirect the LSM label write operation so that it is ineffective. The attacker must cause the user to run a malicious container image that redirects the mount of /proc to the destination of a shared mount, either known to be configured on the target system, or that will be specified by the user when running the container. The attacker must also control the content of the shared mount, for example through another malicious container which also binds it, or as a user with relevant permissions on the host system it is bound from. This vulnerability is fixed in SingularityCE 4.3.5 and SingularityPRO 4.1.11 and 4.3.5.

Weakness: CWE-706, CWE-61

Which versions are affected by CVE-2025-64750?

6 open source packages ship an affected version, including github.com/sylabs/singularity/v4 and github.com/sylabs/singularity.

PackageAffectedFixed in
github.com/sylabs/singularity/v4 GoAll versionsNone
github.com/sylabs/singularity/v4 GoAll versions4.1.11
github.com/sylabs/singularity/v4 GoAll versions4.1.11
github.com/sylabs/singularity/v4 GoFrom 4.2.0-rc.14.3.5
github.com/sylabs/singularity/v4 GoFrom 4.2.0-rc.14.3.5
github.com/sylabs/singularity GoAll versionsNone

How do I fix CVE-2025-64750?

Upgrade github.com/sylabs/singularity/v4 to a fixed version for your release line: 4.1.11 or 4.3.5.

Is CVE-2025-64750 being exploited?

There is no known exploitation of CVE-2025-64750 in the wild and no public exploit code.

Sources

Also known as GHSA-wwrx-w7c9-rf87, GO-2025-4177, UBUNTU-CVE-2025-64750.

Is CVE-2025-64750 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free