# CVE-2025-64750: Singluarity ineffectively applies of selinux / apparmor LSM process labels

> Attackers can bypass SELinux/AppArmor restrictions by redirecting LSM label writes via malicious container mounts, requiring specific host configurations.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-wwrx-w7c9-rf87, GO-2025-4177, UBUNTU-CVE-2025-64750

## What is CVE-2025-64750?

CVE-2025-64750 is a medium-severity vulnerability in sylabs singularity, published on 2 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

SingularityCE and SingularityPRO are open source container platforms. Prior to SingularityCE 4.3.5 and SingularityPRO 4.1.11 and 4.3.5, if a user relies on LSM restrictions to prevent malicious operations then, under certain circumstances, an attacker can redirect the LSM label write operation so that it is ineffective. The attacker must cause the user to run a malicious container image that redirects the mount of /proc to the destination of a shared mount, either known to be configured on the target system, or that will be specified by the user when running the container. The attacker must also control the content of the shared mount, for example through another malicious container which also binds it, or as a user with relevant permissions on the host system it is bound from. This vulnerability is fixed in SingularityCE 4.3.5 and SingularityPRO 4.1.11 and 4.3.5.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference), CWE-61 (UNIX Symbolic Link (Symlink) Following)

## Which versions are affected by CVE-2025-64750?

6 open source packages ship an affected version, including github.com/sylabs/singularity/v4 and github.com/sylabs/singularity.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sylabs/singularity/v4` | Go | All versions | None |
| `github.com/sylabs/singularity/v4` | Go | All versions | 4.1.11 |
| `github.com/sylabs/singularity/v4` | Go | All versions | 4.1.11 |
| `github.com/sylabs/singularity/v4` | Go | From 4.2.0-rc.1 | 4.3.5 |
| `github.com/sylabs/singularity/v4` | Go | From 4.2.0-rc.1 | 4.3.5 |
| `github.com/sylabs/singularity` | Go | All versions | None |

## How do I fix CVE-2025-64750?

Upgrade github.com/sylabs/singularity/v4 to a fixed version for your release line: 4.1.11 or 4.3.5.

## Is CVE-2025-64750 being exploited?

There is no known exploitation of CVE-2025-64750 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64750 and fix it if it is affected.

What it is: CVE-2025-64750 is a medium-severity vulnerability in sylabs singularity, published on 2 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64750 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/sylabs/singularity/v4 (Go): affected all versions; no fix listed
- github.com/sylabs/singularity/v4 (Go): affected all versions; fixed in 4.1.11
- github.com/sylabs/singularity/v4 (Go): affected all versions; fixed in 4.1.11
- github.com/sylabs/singularity/v4 (Go): affected from 4.2.0-rc.1; fixed in 4.3.5
- github.com/sylabs/singularity/v4 (Go): affected from 4.2.0-rc.1; fixed in 4.3.5
- github.com/sylabs/singularity (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64750/ (Markdown: https://insights.sbomify.com/CVE-2025-64750/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64750
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64750
- OSV: https://osv.dev/vulnerability/CVE-2025-64750

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64750/
Summaries are generated and may contain mistakes; the official description above is the record.
