CVE-2025-64751 OpenFGA Improper Policy Enforcement
Attackers can bypass authorization checks in OpenFGA, potentially accessing unauthorized resources or actions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64751?
CVE-2025-64751 is a medium-severity missing authorization vulnerability in openfga, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.
Weakness: CWE-285
Which versions are affected by CVE-2025-64751?
3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openfga/openfga Go | From 1.4.0 | 1.11.1 |
github.com/openfga/openfga Go | From 1.4.0 | 1.11.1 |
github.com/openfga/openfga Go | From 1.4.0 | 1.11.1 |
Products include Openfga Helm Charts, Openfga Openfga.
How do I fix CVE-2025-64751?
Upgrade github.com/openfga/openfga to 1.11.1 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-64751 being exploited?
There is no known exploitation of CVE-2025-64751 in the wild and no public exploit code.
Other vulnerabilities in openfga
Sources
Also known as GHSA-2c64-vmv2-hgfc, GO-2025-4150, MINI-427m-r9j4-3x7v, MINI-697w-qjx6-wh92, MINI-6jp8-qrhp-5x6j, MINI-8wwm-hpfm-7f78 and 10 more.