# CVE-2025-64751: OpenFGA Improper Policy Enforcement

> Attackers can bypass authorization checks in OpenFGA, potentially accessing unauthorized resources or actions.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2025
- **Updated:** 24 Nov 2025
- **Also known as:** GHSA-2c64-vmv2-hgfc, GO-2025-4150, MINI-427m-r9j4-3x7v, MINI-697w-qjx6-wh92, MINI-6jp8-qrhp-5x6j, MINI-8wwm-hpfm-7f78, MINI-8xxm-hxfr-f35g, MINI-ccw5-4634-6gqq, MINI-f539-fqg9-h57f, MINI-gwq5-p2fw-r957, MINI-hhf8-856w-q62g, MINI-hv58-56w6-g4qc, MINI-m3w7-r3r3-8c96, MINI-m5vp-422r-8vgp, MINI-p75m-4798-4fgx, MINI-v9mx-c5vr-mrf3

## What is CVE-2025-64751?

CVE-2025-64751 is a medium-severity missing authorization vulnerability in openfga, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-64751?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | From 1.4.0 | 1.11.1 |
| `github.com/openfga/openfga` | Go | From 1.4.0 | 1.11.1 |
| `github.com/openfga/openfga` | Go | From 1.4.0 | 1.11.1 |

Products: Openfga Helm Charts, Openfga Openfga.

## How do I fix CVE-2025-64751?

Upgrade github.com/openfga/openfga to 1.11.1 or later.

## Is CVE-2025-64751 being exploited?

There is no known exploitation of CVE-2025-64751 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2026-55689](https://insights.sbomify.com/CVE-2026-55689/): OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset (medium 6.8)
- [CVE-2026-24851](https://insights.sbomify.com/CVE-2026-24851/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-55213](https://insights.sbomify.com/CVE-2025-55213/): OpenFGA Authorization Bypass (Check) (medium 5.8)
- [CVE-2025-48371](https://insights.sbomify.com/CVE-2025-48371/): OpenFGA Authorization Bypass (medium 5.8)
- [CVE-2025-46331](https://insights.sbomify.com/CVE-2025-46331/): OpenFGA Authorization Bypass (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64751 and fix it if it is affected.

What it is: CVE-2025-64751 is a medium-severity missing authorization vulnerability in openfga, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64751 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected from 1.4.0; fixed in 1.11.1
- github.com/openfga/openfga (Go): affected from 1.4.0; fixed in 1.11.1
- github.com/openfga/openfga (Go): affected from 1.4.0; fixed in 1.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64751/ (Markdown: https://insights.sbomify.com/CVE-2025-64751/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64751
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64751
- OSV: https://osv.dev/vulnerability/CVE-2025-64751

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64751/
Summaries are generated and may contain mistakes; the official description above is the record.
