# CVE-2025-64755: @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes

> Attackers can bypass read-only validation in Claude Code to write arbitrary files on the host system via sed command injection.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Nov 2025
- **Updated:** 24 Nov 2025
- **Also known as:** GHSA-7mv8-j34q-vp7q

## What is CVE-2025-64755?

CVE-2025-64755 is a high-severity command injection vulnerability in anthropics claude-code, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool. Prior to version 2.0.31, due to an error in sed command parsing, it was possible to bypass the Claude Code read-only validation and write to arbitrary files on the host system. This issue has been patched in version 2.0.31.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-64755?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | All versions | 2.0.31 |
| `@anthropic-ai/claude-code` | npm | All versions | 2.0.31 |

Products: Anthropic Claude Code.

## How do I fix CVE-2025-64755?

Upgrade @anthropic-ai/claude-code to 2.0.31 or later.

## Is CVE-2025-64755 being exploited?

There is no known exploitation of CVE-2025-64755 in the wild and no public exploit code.

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-58764](https://insights.sbomify.com/CVE-2025-58764/): Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)
- [CVE-2025-54795](https://insights.sbomify.com/CVE-2025-54795/): Claude Code echo command allowed bypass of user approval prompt for command execution (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64755 and fix it if it is affected.

What it is: CVE-2025-64755 is a high-severity command injection vulnerability in anthropics claude-code, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64755 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.0.31
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.0.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64755/ (Markdown: https://insights.sbomify.com/CVE-2025-64755/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64755
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64755
- OSV: https://osv.dev/vulnerability/CVE-2025-64755

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64755/
Summaries are generated and may contain mistakes; the official description above is the record.
