{"answers":{"affected":"4 open source packages ship an affected version, including glob. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-64756 in the wild and no public exploit code.","fix":"Upgrade glob to a fixed version for your release line: 10.5.0 or 11.1.0.","what":"CVE-2025-64756 is a high-severity command injection vulnerability in isaacs node-glob, published on 17 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64756 and fix it if it is affected.\n\nWhat it is: CVE-2025-64756 is a high-severity command injection vulnerability in isaacs node-glob, published on 17 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64756 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- glob (npm): affected from 10.2.0; fixed in 10.5.0\n- glob (npm): affected from 10.2.0; fixed in 10.5.0\n- glob (npm): affected from 11.0.0; fixed in 11.1.0\n- glob (npm): affected from 11.0.0; fixed in 11.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64756/ (Markdown: https://insights.sbomify.com/CVE-2025-64756/index.md)","id":"CVE-2025-64756","markdown":"https://insights.sbomify.com/CVE-2025-64756/index.md","name":"CVE-2025-64756","record":{"aliases":["BELL-CVE-2025-64756","CLEANSTART-2026-HY98415","CLEANSTART-2026-TH89899","CLSA-2026-1781830588","CLSA-2026-1781830590","ECHO-840f-d5ce-2603","GHSA-5j98-mcp5-4vw2","MINI-2459-hf3r-4v73","MINI-2mv9-8m4c-4r7f","MINI-5748-4rvf-8c83","MINI-5r94-9gvj-5r5v","MINI-68rg-7v88-q2ch","MINI-6w7m-9pfq-rcx3","MINI-9673-g3fg-pmh2","MINI-cfp5-87q2-f4hp","MINI-g2hq-g6c7-r9mx","MINI-ghwr-fx86-596c","MINI-j296-gmf7-fr5c","MINI-j2c5-vj5g-43xr","MINI-jj96-8mhh-vrx8","MINI-jqr7-j766-q252","MINI-q9vq-p8hj-62q6","MINI-vpfw-vgx8-w6jj","MINI-vqx6-4526-jjcr","MINI-wwc7-3mj2-xgc6","MINI-xf62-pcgr-q76c","MINI-xh62-4958-j2pp","ROOT-APP-NPM-CVE-2025-64756","openSUSE-SU-2025:15775-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js glob library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands via shell metacharacters in filenames when using the glob CLI's command option.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"glob","vendor":"isaacs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Glob matches files using patterns the shell uses. Starting in version 10.2.0 and prior to versions 10.5.0 and 11.1.0, the glob CLI contains a command injection vulnerability in its -c/--cmd option that allows arbitrary command execution when processing files with malicious names. When glob -c \u003ccommand\u003e \u003cpatterns\u003e are used, matched filenames are passed to a shell with shell: true, enabling shell metacharacters in filenames to trigger command injection and achieve arbitrary code execution under the user or CI account privileges. This issue has been patched in versions 10.5.0 and 11.1.0.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"glob CLI: Command injection via -c/--cmd executes matches with shell:true","id":"CVE-2025-64756","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":5,"n_references":3,"next":{"headline":"Astro Development Server is Vulnerable to Arbitrary Local File Read","id":"CVE-2025-64757"},"packages":[{"ecosystem":"npm","fixed":["10.5.0"],"introduced":["10.2.0"],"last_affected":[],"package":"glob","purl":null,"source":"GHSA-5j98-mcp5-4vw2"},{"ecosystem":"npm","fixed":["10.5.0"],"introduced":["10.2.0"],"last_affected":[],"package":"glob","purl":"pkg:npm/glob","source":"GHSA-5j98-mcp5-4vw2"},{"ecosystem":"npm","fixed":["11.1.0"],"introduced":["11.0.0"],"last_affected":[],"package":"glob","purl":null,"source":"GHSA-5j98-mcp5-4vw2"},{"ecosystem":"npm","fixed":["11.1.0"],"introduced":["11.0.0"],"last_affected":[],"package":"glob","purl":"pkg:npm/glob","source":"GHSA-5j98-mcp5-4vw2"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.11.0-1.1"],"introduced":["0"],"last_affected":[],"package":"opa","purl":"pkg:rpm/opensuse/opa\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15775-1"}],"prev":{"headline":"@anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes","id":"CVE-2025-64755"},"products":["node-glob"],"published":"2025-11-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-19","vendors":["isaacs"]},"summary":"Attackers can execute arbitrary commands via shell metacharacters in filenames when using the glob CLI's command option.","url":"https://insights.sbomify.com/CVE-2025-64756/"}