{"answers":{"affected":"2 open source packages ship an affected version, including @dependencytrack/frontend.","exploited":"There is no known exploitation of CVE-2025-64758 in the wild and no public exploit code.","fix":"Upgrade @dependencytrack/frontend to 4.13.6 or later.","what":"CVE-2025-64758 is a medium-severity cross-site scripting vulnerability in DependencyTrack frontend, published on 17 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-64758 and fix it if it is affected.\n\nWhat it is: CVE-2025-64758 is a medium-severity cross-site scripting vulnerability in DependencyTrack frontend, published on 17 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-64758 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @dependencytrack/frontend (npm): affected from 4.12.0; fixed in 4.13.6\n- @dependencytrack/frontend (npm): affected from 4.12.0; fixed in 4.13.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64758/ (Markdown: https://insights.sbomify.com/CVE-2025-64758/index.md)","id":"CVE-2025-64758","markdown":"https://insights.sbomify.com/CVE-2025-64758/index.md","name":"CVE-2025-64758","record":{"aliases":["GHSA-7xvh-c266-cfr5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Dependency-Track frontend","requires_auth":"high_privilege","summary":"Administrators can inject arbitrary JavaScript into the login page welcome message, potentially compromising user sessions and data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"@dependencytrack/frontend is a Single Page Application (SPA) used in Dependency-Track, an open source Component Analysis platform that allows organizations to identify and reduce risk in the software supply chain. Since version 4.12.0, Dependency-Track users with the SYSTEM_CONFIGURATION permission can configure a \"welcome message\", which is HTML that is to be rendered on the login page for branding purposes. When rendering the welcome message, Dependency-Track versions before 4.13.6 did not properly sanitize the HTML, allowing arbitrary JavaScript to be executed. Users with the SYSTEM_CONFIGURATION permission (i.e., administrators), can exploit this weakness to execute arbitrary JavaScript for users browsing to the login page. The issue has been fixed in version 4.13.6.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@dependencytrack/frontend Vulnerable to Persistent Cross-Site-Scripting via Welcome Message","id":"CVE-2025-64758","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Homarr is Vulnerable to Stored Cross-Site Scripting (XSS) and Possible Privilege Escalation via Malicious SVG Upload","id":"CVE-2025-64759"},"packages":[{"ecosystem":"npm","fixed":["4.13.6"],"introduced":["4.12.0"],"last_affected":[],"package":"@dependencytrack/frontend","purl":null,"source":"GHSA-7xvh-c266-cfr5"},{"ecosystem":"npm","fixed":["4.13.6"],"introduced":["4.12.0"],"last_affected":[],"package":"@dependencytrack/frontend","purl":"pkg:npm/%40dependencytrack/frontend","source":"GHSA-7xvh-c266-cfr5"}],"prev":{"headline":"Astro Development Server is Vulnerable to Arbitrary Local File Read","id":"CVE-2025-64757"},"products":["frontend"],"published":"2025-11-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-17","vendors":["DependencyTrack"]},"summary":"Administrators can inject arbitrary JavaScript into the login page welcome message, potentially compromising user sessions and data.","url":"https://insights.sbomify.com/CVE-2025-64758/"}