# CVE-2025-64758: @dependencytrack/frontend Vulnerable to Persistent Cross-Site-Scripting via Welcome Message

> Administrators can inject arbitrary JavaScript into the login page welcome message, potentially compromising user sessions and data.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Nov 2025
- **Updated:** 17 Nov 2025
- **Also known as:** GHSA-7xvh-c266-cfr5

## What is CVE-2025-64758?

CVE-2025-64758 is a medium-severity cross-site scripting vulnerability in DependencyTrack frontend, published on 17 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

@dependencytrack/frontend is a Single Page Application (SPA) used in Dependency-Track, an open source Component Analysis platform that allows organizations to identify and reduce risk in the software supply chain. Since version 4.12.0, Dependency-Track users with the SYSTEM_CONFIGURATION permission can configure a "welcome message", which is HTML that is to be rendered on the login page for branding purposes. When rendering the welcome message, Dependency-Track versions before 4.13.6 did not properly sanitize the HTML, allowing arbitrary JavaScript to be executed. Users with the SYSTEM_CONFIGURATION permission (i.e., administrators), can exploit this weakness to execute arbitrary JavaScript for users browsing to the login page. The issue has been fixed in version 4.13.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-64758?

2 open source packages ship an affected version, including @dependencytrack/frontend.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@dependencytrack/frontend` | npm | From 4.12.0 | 4.13.6 |
| `@dependencytrack/frontend` | npm | From 4.12.0 | 4.13.6 |

## How do I fix CVE-2025-64758?

Upgrade @dependencytrack/frontend to 4.13.6 or later.

## Is CVE-2025-64758 being exploited?

There is no known exploitation of CVE-2025-64758 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64758 and fix it if it is affected.

What it is: CVE-2025-64758 is a medium-severity cross-site scripting vulnerability in DependencyTrack frontend, published on 17 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64758 in the wild and no public exploit code.

Affected packages and fixed versions:
- @dependencytrack/frontend (npm): affected from 4.12.0; fixed in 4.13.6
- @dependencytrack/frontend (npm): affected from 4.12.0; fixed in 4.13.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64758/ (Markdown: https://insights.sbomify.com/CVE-2025-64758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64758
- OSV: https://osv.dev/vulnerability/CVE-2025-64758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64758/
Summaries are generated and may contain mistakes; the official description above is the record.
