# CVE-2025-64761: OpenBao Privileged Operator Identity Group Root Escalation

> A privileged operator can escalate permissions to root by adding a root policy to an identity group, bypassing intended access controls.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-openbao-2025-64761, GHSA-7ff4-jw48-3436, GO-2025-4156, openSUSE-SU-2025:15767-1

## What is CVE-2025-64761?

CVE-2025-64761 is a high-severity vulnerability in openbao, published on 25 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenBao is an open source identity-based secrets management system. Prior to version 2.4.4, a privileged operator could use the identity group subsystem to add a root policy to a group identity group, escalating their or another user's permissions in the system. Specifically this is an issue when: an operator in the root namespace has access to identity/groups endpoints and an operator does not have policy access. Otherwise, an operator with policy access could create or modify an existing policy to grant root-equivalent permissions through the sudo capability. This issue has been patched in version 2.4.4.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-64761?

4 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | None |
| `github.com/openbao/openbao` | Go | All versions | 2.4.4 |
| `github.com/openbao/openbao` | Go | All versions | 2.4.4 |
| `openbao` | Bitnami | All versions | 2.4.4 |
| `openbao` | openSUSE:Tumbleweed | All versions | 2.4.4-1.1 |

Products: Openbao Openbao.

## How do I fix CVE-2025-64761?

Upgrade github.com/openbao/openbao to 2.4.4 or later.

## Is CVE-2025-64761 being exploited?

There is no known exploitation of CVE-2025-64761 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)
- [CVE-2025-54996](https://insights.sbomify.com/CVE-2025-54996/): OpenBao Root Namespace Operator May Elevate Token Privileges (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64761 and fix it if it is affected.

What it is: CVE-2025-64761 is a high-severity vulnerability in openbao, published on 25 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64761 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; no fix listed
- github.com/openbao/openbao (Go): affected all versions; fixed in 2.4.4
- github.com/openbao/openbao (Go): affected all versions; fixed in 2.4.4
- openbao (Bitnami): affected all versions; fixed in 2.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64761/ (Markdown: https://insights.sbomify.com/CVE-2025-64761/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64761
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64761
- OSV: https://osv.dev/vulnerability/CVE-2025-64761

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64761/
Summaries are generated and may contain mistakes; the official description above is the record.
