{"answers":{"affected":"2 open source packages ship an affected version, including @hpke/core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64767 exists.","fix":"Upgrade @hpke/core to 1.7.5 or later.","what":"CVE-2025-64767 is a critical vulnerability in dajiaji hpke-js, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64767 and fix it if it is affected.\n\nWhat it is: CVE-2025-64767 is a critical vulnerability in dajiaji hpke-js, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64767 exists.\n\nAffected packages and fixed versions:\n- @hpke/core (npm): affected all versions; fixed in 1.7.5\n- @hpke/core (npm): affected all versions; fixed in 1.7.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64767/ (Markdown: https://insights.sbomify.com/CVE-2025-64767/index.md)","id":"CVE-2025-64767","markdown":"https://insights.sbomify.com/CVE-2025-64767/index.md","name":"CVE-2025-64767","record":{"aliases":["GHSA-73g8-5h73-26h4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"HPKE JavaScript library","requires_auth":"none","summary":"A race condition in the Seal API allows AEAD nonce reuse, compromising message confidentiality and integrity in the hpke-js library.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-323","name":"Reusing a Nonce, Key Pair in Encryption"}],"description":"hpke-js is a Hybrid Public Key Encryption (HPKE) module built on top of Web Cryptography API. Prior to version 1.7.5, the public SenderContext Seal() API has a race condition which allows for the same AEAD nonce to be re-used for multiple Seal() calls. This can lead to complete loss of Confidentiality and Integrity of the produced messages. This issue has been patched in version 1.7.5.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"hpke-js reuses AEAD nonces","id":"CVE-2025-64767","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"race_condition","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"AVEVA Process Optimization Cleartext Transmission of Sensitive Information","id":"CVE-2025-64769"},"packages":[{"ecosystem":"npm","fixed":["1.7.5"],"introduced":["0"],"last_affected":[],"package":"@hpke/core","purl":null,"source":"GHSA-73g8-5h73-26h4"},{"ecosystem":"npm","fixed":["1.7.5"],"introduced":["0"],"last_affected":[],"package":"@hpke/core","purl":"pkg:npm/%40hpke/core","source":"GHSA-73g8-5h73-26h4"}],"prev":{"headline":"NixOS has hardcoded credentials in Onlyoffice module","id":"CVE-2025-64766"},"products":["hpke-js"],"published":"2025-11-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-21","vendors":["dajiaji"]},"summary":"A race condition in the Seal API allows AEAD nonce reuse, compromising message confidentiality and integrity in the hpke-js library.","url":"https://insights.sbomify.com/CVE-2025-64767/"}