# CVE-2025-64767: hpke-js reuses AEAD nonces

> A race condition in the Seal API allows AEAD nonce reuse, compromising message confidentiality and integrity in the hpke-js library.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2025
- **Updated:** 21 Nov 2025
- **Also known as:** GHSA-73g8-5h73-26h4

## What is CVE-2025-64767?

CVE-2025-64767 is a critical vulnerability in dajiaji hpke-js, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

hpke-js is a Hybrid Public Key Encryption (HPKE) module built on top of Web Cryptography API. Prior to version 1.7.5, the public SenderContext Seal() API has a race condition which allows for the same AEAD nonce to be re-used for multiple Seal() calls. This can lead to complete loss of Confidentiality and Integrity of the produced messages. This issue has been patched in version 1.7.5.

Weakness: CWE-323 (Reusing a Nonce, Key Pair in Encryption)

## Which versions are affected by CVE-2025-64767?

2 open source packages ship an affected version, including @hpke/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hpke/core` | npm | All versions | 1.7.5 |
| `@hpke/core` | npm | All versions | 1.7.5 |

## How do I fix CVE-2025-64767?

Upgrade @hpke/core to 1.7.5 or later.

## Is CVE-2025-64767 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64767 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64767 and fix it if it is affected.

What it is: CVE-2025-64767 is a critical vulnerability in dajiaji hpke-js, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64767 exists.

Affected packages and fixed versions:
- @hpke/core (npm): affected all versions; fixed in 1.7.5
- @hpke/core (npm): affected all versions; fixed in 1.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64767/ (Markdown: https://insights.sbomify.com/CVE-2025-64767/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64767
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64767
- OSV: https://osv.dev/vulnerability/CVE-2025-64767

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64767/
Summaries are generated and may contain mistakes; the official description above is the record.
