CVE-2025-64775 Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS)
Attackers can cause disk exhaustion and denial of service by exploiting a file leak in Apache Struts multipart request processing.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64775?
CVE-2025-64775 is a high-severity denial of service vulnerability in Apache Struts, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
Weakness: CWE-459
Which versions are affected by CVE-2025-64775?
8 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | From 2.0.0 to 2.3.37 | None |
org.apache.struts:struts2-core Maven | From 2.0.0 to 2.3.37 | None |
org.apache.struts:struts2-core Maven | From 2.5.0 to 2.5.33 | None |
org.apache.struts:struts2-core Maven | From 2.5.0 to 2.5.33 | None |
org.apache.struts:struts2-core Maven | From 6.0.0 | 6.8.0 |
org.apache.struts:struts2-core Maven | From 6.0.0 | 6.8.0 |
2 more packages
org.apache.struts:struts2-core Maven | From 7.0.0 | 7.1.1 |
org.apache.struts:struts2-core Maven | From 7.0.0 | 7.1.1 |
Products include Apache Struts.
How do I fix CVE-2025-64775?
Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 6.8.0 or 7.1.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-64775 being exploited?
There is no known exploitation of CVE-2025-64775 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-xx7v-hqxh-cjr9.