CVE-2025-6491 NULL Pointer Dereference in PHP SOAP Extension via Large XML Namespace Prefix
Attackers can cause server crashes by sending large XML namespace prefixes to the PHP SOAP extension, impacting availability.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6491?
CVE-2025-6491 is a medium-severity vulnerability in Php Php, published on 13 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions:8.1.* before 8.1.33, 8.2.* before 8.2.29, 8.3.* before 8.3.23, 8.4.* before 8.4.10 when parsing XML data in SOAP extensions, overly large (>2Gb) XML namespace prefix may lead to null pointer dereference. This may lead to crashes and affect the availability of the target server.
Weakness: CWE-476
Which versions are affected by CVE-2025-6491?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
php Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
php-min Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
Products include Php Php.
How do I fix CVE-2025-6491?
Upgrade libphp to a fixed version for your release line: 8.1.33, 8.2.29, 8.3.23 or 8.4.10.
Is CVE-2025-6491 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6491 exists.
Other vulnerabilities in Php Php
Sources
Also known as AZL-65118, AZL-65127, BELL-CVE-2025-6491, BIT-libphp-2025-6491, BIT-php-2025-6491, BIT-php-min-2025-6491 and 13 more.