# CVE-2025-6491: NULL Pointer Dereference in PHP SOAP Extension via Large XML Namespace Prefix

> Attackers can cause server crashes by sending large XML namespace prefixes to the PHP SOAP extension, impacting availability.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** AZL-65118, AZL-65127, BELL-CVE-2025-6491, BIT-libphp-2025-6491, BIT-php-2025-6491, BIT-php-min-2025-6491, CLSA-2025-1754342894, CLSA-2025-1754381195, CLSA-2025-1754384758, CLSA-2025-1760017411, CLSA-2025-1760017744, DEBIAN-CVE-2025-6491, ECHO-950f-f0b4-71aa, GHSA-453j-q27h-5p8x, MINI-j54g-3mg6-pcqw, MINI-pm3g-hpw8-94wp, MINI-qmxg-gxxc-qgj5, MINI-vm4h-96mx-gjx6, UBUNTU-CVE-2025-6491

## What is CVE-2025-6491?

CVE-2025-6491 is a medium-severity vulnerability in Php Php, published on 13 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions:8.1.* before 8.1.33, 8.2.* before 8.2.29, 8.3.* before 8.3.23, 8.4.* before 8.4.10 when parsing XML data in SOAP extensions, overly large (>2Gb) XML namespace prefix may lead to null pointer dereference. This may lead to crashes and affect the availability of the target server.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2025-6491?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
| `php` | Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
| `php-min` | Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |

Products: Php Php.

## How do I fix CVE-2025-6491?

Upgrade libphp to a fixed version for your release line: 8.1.33, 8.2.29, 8.3.23 or 8.4.10.

## Is CVE-2025-6491 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6491 exists.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6491 and fix it if it is affected.

What it is: CVE-2025-6491 is a medium-severity vulnerability in Php Php, published on 13 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6491 exists.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10
- php (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10
- php-min (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6491/ (Markdown: https://insights.sbomify.com/CVE-2025-6491/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6491
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6491
- OSV: https://osv.dev/vulnerability/CVE-2025-6491

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6491/
Summaries are generated and may contain mistakes; the official description above is the record.
