CVE-2025-65012 Kirby CMS has cross-site scripting (XSS) in the changes dialog
Authenticated attackers can inject malicious scripts via page titles or usernames, executing code in other users' panels.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-65012?
CVE-2025-65012 is a medium-severity cross-site scripting vulnerability in getkirby kirby, published on 18 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Kirby is an open-source content management system. From versions 5.0.0 to 5.1.3, attackers could change the title of any page or the name of any user to a malicious string. Then they could modify any content field of the same model without saving, making the model a candidate for display in the "Changes" dialog. If another authenticated user subsequently opened the dialog in their Panel, the malicious code would be executed. This vulnerability affects all Kirby 5 sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to update page titles or usernames. The attack requires user interaction by another Panel user and cannot be automated. This issue has been patched in version 5.1.4.
Weakness: CWE-79
Which versions are affected by CVE-2025-65012?
2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | From 5.0.0 | 5.1.4 |
getkirby/cms Packagist | From 5.0.0 | 5.1.4 |
Products include Getkirby Kirby.
How do I fix CVE-2025-65012?
Upgrade getkirby/cms to 5.1.4 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-65012 being exploited?
There is no known exploitation of CVE-2025-65012 in the wild and no public exploit code.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-84hf-8gh5-575j.