{"answers":{"affected":"2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-65012 in the wild and no public exploit code.","fix":"Upgrade getkirby/cms to 5.1.4 or later.","what":"CVE-2025-65012 is a medium-severity cross-site scripting vulnerability in getkirby kirby, published on 18 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-65012 and fix it if it is affected.\n\nWhat it is: CVE-2025-65012 is a medium-severity cross-site scripting vulnerability in getkirby kirby, published on 18 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-65012 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.1.4\n- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65012/ (Markdown: https://insights.sbomify.com/CVE-2025-65012/index.md)","id":"CVE-2025-65012","markdown":"https://insights.sbomify.com/CVE-2025-65012/index.md","name":"CVE-2025-65012","record":{"aliases":["GHSA-84hf-8gh5-575j"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Kirby CMS","requires_auth":"low_privilege","summary":"Authenticated attackers can inject malicious scripts via page titles or usernames, executing code in other users' panels.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"kirby","vendor":"getkirby"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Kirby is an open-source content management system. From versions 5.0.0 to 5.1.3, attackers could change the title of any page or the name of any user to a malicious string. Then they could modify any content field of the same model without saving, making the model a candidate for display in the \"Changes\" dialog. If another authenticated user subsequently opened the dialog in their Panel, the malicious code would be executed. This vulnerability affects all Kirby 5 sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to update page titles or usernames. The attack requires user interaction by another Panel user and cannot be automated. This issue has been patched in version 5.1.4.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kirby CMS has cross-site scripting (XSS) in the changes dialog","id":"CVE-2025-65012","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"LibreNMS vulnerable to Reflected Cross-Site Scripting (XSS) in endpoint `/maps/nodeimage` parameter `Image Name`","id":"CVE-2025-65013"},"packages":[{"ecosystem":"Packagist","fixed":["5.1.4"],"introduced":["5.0.0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-84hf-8gh5-575j"},{"ecosystem":"Packagist","fixed":["5.1.4"],"introduced":["5.0.0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-84hf-8gh5-575j"}],"prev":{"headline":"Unauthorized Access to files in WODESYS WD-R608U router","id":"CVE-2025-65011"},"products":["kirby"],"published":"2025-11-18","related":[{"cvss_score":8.8,"headline":"Kirby vulnerable to unrestricted file upload of user avatar images","id":"CVE-2024-26483","kev_date_added":null,"published":"2024-02-22"},{"cvss_score":8.1,"headline":"Insufficient permission checks in the language settings in Kirby CMS","id":"CVE-2024-41964","kev_date_added":null,"published":"2024-08-29"},{"cvss_score":7.6,"headline":"Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering","id":"CVE-2026-34587","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":7.6,"headline":"Cross-site scripting (XSS) from unsanitized uploaded SVG files","id":"CVE-2021-29460","kev_date_added":null,"published":"2021-04-27"},{"cvss_score":7.3,"headline":"Kirby vulnerable to Insufficient Session Expiration after a password change","id":"CVE-2023-38489","kev_date_added":null,"published":"2023-07-27"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from writer field content in the site frontend","id":"CVE-2021-41252","kev_date_added":null,"published":"2021-11-16"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from image block content in the site frontend","id":"CVE-2021-41258","kev_date_added":null,"published":"2021-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-19","vendors":["getkirby"]},"summary":"Authenticated attackers can inject malicious scripts via page titles or usernames, executing code in other users' panels.","url":"https://insights.sbomify.com/CVE-2025-65012/"}