# CVE-2025-65012: Kirby CMS has cross-site scripting (XSS) in the changes dialog

> Authenticated attackers can inject malicious scripts via page titles or usernames, executing code in other users' panels.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Nov 2025
- **Updated:** 19 Nov 2025
- **Also known as:** GHSA-84hf-8gh5-575j

## What is CVE-2025-65012?

CVE-2025-65012 is a medium-severity cross-site scripting vulnerability in getkirby kirby, published on 18 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Kirby is an open-source content management system. From versions 5.0.0 to 5.1.3, attackers could change the title of any page or the name of any user to a malicious string. Then they could modify any content field of the same model without saving, making the model a candidate for display in the "Changes" dialog. If another authenticated user subsequently opened the dialog in their Panel, the malicious code would be executed. This vulnerability affects all Kirby 5 sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to update page titles or usernames. The attack requires user interaction by another Panel user and cannot be automated. This issue has been patched in version 5.1.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-65012?

2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.1.4 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.1.4 |

Products: Getkirby Kirby.

## How do I fix CVE-2025-65012?

Upgrade getkirby/cms to 5.1.4 or later.

## Is CVE-2025-65012 being exploited?

There is no known exploitation of CVE-2025-65012 in the wild and no public exploit code.

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65012 and fix it if it is affected.

What it is: CVE-2025-65012 is a medium-severity cross-site scripting vulnerability in getkirby kirby, published on 18 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-65012 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.1.4
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65012/ (Markdown: https://insights.sbomify.com/CVE-2025-65012/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65012
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65012
- OSV: https://osv.dev/vulnerability/CVE-2025-65012

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65012/
Summaries are generated and may contain mistakes; the official description above is the record.
