{"answers":{"affected":"4 open source packages ship an affected version, including decidim and decidim-core. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65017 exists.","fix":"Upgrade decidim to 0.30.4 or later.","what":"CVE-2025-65017 is a high-severity vulnerability in decidim, published on 3 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-65017 and fix it if it is affected.\n\nWhat it is: CVE-2025-65017 is a high-severity vulnerability in decidim, published on 3 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65017 exists.\n\nAffected packages and fixed versions:\n- decidim (RubyGems): affected from 0.30.0; fixed in 0.30.4\n- decidim (RubyGems): affected from 0.30.0; fixed in 0.30.4\n- decidim-core (RubyGems): affected from 0.30.0; fixed in 0.30.4\n- decidim-core (RubyGems): affected from 0.30.0; fixed in 0.30.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65017/ (Markdown: https://insights.sbomify.com/CVE-2025-65017/index.md)","id":"CVE-2025-65017","markdown":"https://insights.sbomify.com/CVE-2025-65017/index.md","name":"CVE-2025-65017","record":{"aliases":["GHSA-3cx6-j9j4-54mp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy","requires_auth":"low_privilege","summary":"Attackers can access private data exports due to UUID collisions, exposing sensitive information in Decidim participatory democracy platforms.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"decidim","vendor":"decidim"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-703","name":"Improper Check or Handling of Exceptional Conditions"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Decidim is a participatory democracy framework. In versions from 0.30.0 to before 0.30.4 and from 0.31.0.rc1 to before 0.31.0, the private data exports can lead to data leaks in case the UUID generation, causing collisions for the generated UUIDs. This issue has been patched in versions 0.30.4 and 0.31.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Decidim's private data exports can lead to data leaks","id":"CVE-2025-65017","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":4,"n_references":4,"next":{"headline":"LIBPNG is vulnerable to a heap buffer overflow in `png_combine_row` triggered via `png_image_finish_read`","id":"CVE-2025-65018"},"packages":[{"ecosystem":"RubyGems","fixed":["0.30.4"],"introduced":["0.30.0"],"last_affected":[],"package":"decidim","purl":null,"source":"GHSA-3cx6-j9j4-54mp"},{"ecosystem":"RubyGems","fixed":["0.30.4"],"introduced":["0.30.0"],"last_affected":[],"package":"decidim","purl":"pkg:gem/decidim","source":"GHSA-3cx6-j9j4-54mp"},{"ecosystem":"RubyGems","fixed":["0.30.4"],"introduced":["0.30.0"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-3cx6-j9j4-54mp"},{"ecosystem":"RubyGems","fixed":["0.30.4"],"introduced":["0.30.0"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-3cx6-j9j4-54mp"}],"prev":{"headline":"joserfc has Possible Uncontrolled Resource Consumption Vulnerability Triggered by Logging Arbitrarily Large JWT Token Payloads","id":"CVE-2025-65015"},"products":["decidim"],"published":"2026-02-03","related":[{"cvss_score":9.3,"headline":"Decidim has a Cross-site scripting (XSS) vulnerability via user name field","id":"CVE-2026-23891","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":9.1,"headline":"Decidim has broken access control in templates","id":"CVE-2023-36465","kev_date_added":null,"published":"2023-10-06"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the external link redirections","id":"CVE-2023-32693","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the processes filter","id":"CVE-2023-34089","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":7.7,"headline":"Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds","id":"CVE-2024-45594","kev_date_added":null,"published":"2024-11-13"},{"cvss_score":7.5,"headline":"Decidim amendments can be accepted or rejected by anyone","id":"CVE-2026-40869","kev_date_added":null,"published":"2026-04-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-03","vendors":["decidim"]},"summary":"Attackers can access private data exports due to UUID collisions, exposing sensitive information in Decidim participatory democracy platforms.","url":"https://insights.sbomify.com/CVE-2025-65017/"}