# CVE-2025-65017: Decidim's private data exports can lead to data leaks

> Attackers can access private data exports due to UUID collisions, exposing sensitive information in Decidim participatory democracy platforms.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Feb 2026
- **Updated:** 3 Feb 2026
- **Also known as:** GHSA-3cx6-j9j4-54mp

## What is CVE-2025-65017?

CVE-2025-65017 is a high-severity vulnerability in decidim, published on 3 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Decidim is a participatory democracy framework. In versions from 0.30.0 to before 0.30.4 and from 0.31.0.rc1 to before 0.31.0, the private data exports can lead to data leaks in case the UUID generation, causing collisions for the generated UUIDs. This issue has been patched in versions 0.30.4 and 0.31.0.

Weakness: CWE-703 (Improper Check or Handling of Exceptional Conditions), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-65017?

4 open source packages ship an affected version, including decidim and decidim-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim` | RubyGems | From 0.30.0 | 0.30.4 |
| `decidim` | RubyGems | From 0.30.0 | 0.30.4 |
| `decidim-core` | RubyGems | From 0.30.0 | 0.30.4 |
| `decidim-core` | RubyGems | From 0.30.0 | 0.30.4 |

Products: Decidim Decidim.

## How do I fix CVE-2025-65017?

Upgrade decidim to 0.30.4 or later.

## Is CVE-2025-65017 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65017 exists.

## Other vulnerabilities in decidim

- [CVE-2026-23891](https://insights.sbomify.com/CVE-2026-23891/): Decidim has a Cross-site scripting (XSS) vulnerability via user name field (critical 9.3)
- [CVE-2023-36465](https://insights.sbomify.com/CVE-2023-36465/): Decidim has broken access control in templates (critical 9.1)
- [CVE-2023-32693](https://insights.sbomify.com/CVE-2023-32693/): Decidim Cross-site Scripting vulnerability in the external link redirections (high 8.1)
- [CVE-2023-34089](https://insights.sbomify.com/CVE-2023-34089/): Decidim Cross-site Scripting vulnerability in the processes filter (high 8.1)
- [CVE-2024-45594](https://insights.sbomify.com/CVE-2024-45594/): Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65017 and fix it if it is affected.

What it is: CVE-2025-65017 is a high-severity vulnerability in decidim, published on 3 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65017 exists.

Affected packages and fixed versions:
- decidim (RubyGems): affected from 0.30.0; fixed in 0.30.4
- decidim (RubyGems): affected from 0.30.0; fixed in 0.30.4
- decidim-core (RubyGems): affected from 0.30.0; fixed in 0.30.4
- decidim-core (RubyGems): affected from 0.30.0; fixed in 0.30.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65017/ (Markdown: https://insights.sbomify.com/CVE-2025-65017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65017
- OSV: https://osv.dev/vulnerability/CVE-2025-65017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65017/
Summaries are generated and may contain mistakes; the official description above is the record.
