# CVE-2025-65073: OpenStack Keystone allows /v3/ec2tokens or /v3/s3tokens request with valid AWS Signature to provide Keystone authorization.

> Attackers can bypass Keystone authorization using valid AWS signatures on EC2/S3 token endpoints, gaining unauthorized access to OpenStack resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2025
- **Updated:** 17 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-65073, DLA-4367-1, DSA-6056-1, GHSA-hcqg-5g63-7j9h, PYSEC-2026-1490, RHSA-2026:1958, UBUNTU-CVE-2025-65073, USN-7857-1

## What is CVE-2025-65073?

CVE-2025-65073 is a high-severity authentication bypass vulnerability in OpenStack Keystone, published on 17 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenStack Keystone before 26.0.1, 27.0.0, and 28.0.0 allows a /v3/ec2tokens or /v3/s3tokens request with a valid AWS Signature to provide Keystone authorization.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-65073?

7 open source packages ship an affected version, including keystone.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 26.0.1, 27.0.0, 28.0.0 |
| `keystone` | PyPI | All versions | 26.0.1 |
| `keystone` | PyPI | All versions | 26.0.1 |
| `keystone` | PyPI | From 27.0.0.0rc1 | 27.0.0 |
| `keystone` | PyPI | From 27.0.0.0rc1 | 27.0.0 |
| `keystone` | PyPI | From 28.0.0.0rc1 | 28.0.0 |
| `keystone` | PyPI | From 28.0.0.0rc1 | 28.0.0 |
| `openstack-keystone` | Red Hat:openstack:18.0::el9 | All versions | 1:23.0.3-18.0.20241202141842.9e3dfb4.el9ost |
| `python3-keystone` | Red Hat:openstack:18.0::el9 | All versions | 1:23.0.3-18.0.20241202141842.9e3dfb4.el9ost |

## How do I fix CVE-2025-65073?

Upgrade keystone to a fixed version for your release line: 26.0.1, 27.0.0 or 28.0.0.

## Is CVE-2025-65073 being exploited?

There is no known exploitation of CVE-2025-65073 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65073 and fix it if it is affected.

What it is: CVE-2025-65073 is a high-severity authentication bypass vulnerability in OpenStack Keystone, published on 17 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65073 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 26.0.1, 27.0.0, 28.0.0
- keystone (PyPI): affected all versions; fixed in 26.0.1
- keystone (PyPI): affected all versions; fixed in 26.0.1
- keystone (PyPI): affected from 27.0.0.0rc1; fixed in 27.0.0
- keystone (PyPI): affected from 27.0.0.0rc1; fixed in 27.0.0
- keystone (PyPI): affected from 28.0.0.0rc1; fixed in 28.0.0
- keystone (PyPI): affected from 28.0.0.0rc1; fixed in 28.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65073/ (Markdown: https://insights.sbomify.com/CVE-2025-65073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65073
- OSV: https://osv.dev/vulnerability/CVE-2025-65073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65073/
Summaries are generated and may contain mistakes; the official description above is the record.
