CVE-2025-65082 Apache HTTP Server: CGI environment variable override
Attackers can override CGI environment variables via configuration, potentially leading to code execution or security bypasses in Apache HTTP Server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-65082?
CVE-2025-65082 is a medium-severity vulnerability in Apache Http Server, published on 5 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs.
This issue affects Apache HTTP Server from 2.4.0 through 2.4.65.
Users are recommended to upgrade to version 2.4.66 which fixes the issue.
Weakness: CWE-150
Which versions are affected by CVE-2025-65082?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.66 |
Products include Apache Http Server.
How do I fix CVE-2025-65082?
Upgrade apache to 2.4.66 or later.
Is CVE-2025-65082 being exploited?
There is no known exploitation of CVE-2025-65082 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2025-65082, AZL-71525, AZL-71596, BELL-CVE-2025-65082, BIT-apache-2025-65082, DEBIAN-CVE-2025-65082 and 3 more.