# CVE-2025-65094: WBCE CMS is Vulnerable to Privilege Escalation via Group ID Manipulation (IDOR)

> Low-privileged users can escalate to administrator by manipulating group IDs due to missing server-side validation, leading to full CMS compromise.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Nov 2025
- **Updated:** 19 Nov 2025
- **Also known as:** GHSA-hmmw-4ccm-fx44

## What is CVE-2025-65094?

CVE-2025-65094 is a high-severity vulnerability in WBCE_CMS, published on 19 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

WBCE CMS is a content management system. Prior to version 1.6.4, a low-privileged user in WBCE CMS can escalate their privileges to the Administrators group by manipulating the groups[] parameter in the /admin/users/save.php request. The UI restricts users to assigning only their existing group, but server-side validation is missing, allowing attackers to overwrite their group membership and obtain full administrative access. This results in a complete compromise of the CMS. This issue has been patched in version 1.6.4.

Weakness: CWE-285 (Improper Authorization), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-65094?

It affects 1 product.


Products: Wbce Wbce Cms.

## How do I fix CVE-2025-65094?

No fix has been published for CVE-2025-65094 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-65094 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65094 exists.

Public exploit code:

- CVE-2025-65094 - WBCE CMS is Vulnerable to Privilege Escalation via Group ID Manipulation (IDOR) (github_poc): https://github.com/lukasz-rybak/CVE-2025-65094

## Other vulnerabilities in WBCE_CMS

- [CVE-2023-39796](https://insights.sbomify.com/CVE-2023-39796/): SQL injection in n/a (critical 9.8)
- [CVE-2022-46020](https://insights.sbomify.com/CVE-2022-46020/): File upload in n/a (critical 9.8)
- [CVE-2021-3817](https://insights.sbomify.com/CVE-2021-3817/): SQL Injection in wbce/wbce_cms (critical 9.8)
- [CVE-2025-65950](https://insights.sbomify.com/CVE-2025-65950/): WBCE CMS is Vulnerable to Time-Based Blind SQL Injection through groups[] Parameter (critical 9.4)
- [CVE-2025-67504](https://insights.sbomify.com/CVE-2025-67504/): WBCE CMS has Weak Random Number Generator in Password Generation Function (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65094 and fix it if it is affected.

What it is: CVE-2025-65094 is a high-severity vulnerability in WBCE_CMS, published on 19 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65094 exists.

Affected product: WBCE_CMS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65094/ (Markdown: https://insights.sbomify.com/CVE-2025-65094/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65094
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65094
- OSV: https://osv.dev/vulnerability/CVE-2025-65094

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65094/
Summaries are generated and may contain mistakes; the official description above is the record.
