# CVE-2025-65095: Lookyloo is vulnerable due to improper user input sanitization

> Attackers can inject malicious scripts into Lookyloo's index and tree pages, potentially compromising user sessions or executing code.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Nov 2025
- **Updated:** 20 Nov 2025
- **Also known as:** GHSA-m9g6-23c8-vrxf

## What is CVE-2025-65095?

CVE-2025-65095 is a critical cross-site scripting vulnerability in lookyloo, published on 19 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to version 1.35.1, there is potential cross-site scripting on index and tree page. This issue has been patched in version 1.35.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-65095?


## How do I fix CVE-2025-65095?

No fix has been published for CVE-2025-65095 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-65095 being exploited?

There is no known exploitation of CVE-2025-65095 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65095 and fix it if it is affected.

What it is: CVE-2025-65095 is a critical cross-site scripting vulnerability in lookyloo, published on 19 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-65095 in the wild and no public exploit code.

Affected product: lookyloo. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65095/ (Markdown: https://insights.sbomify.com/CVE-2025-65095/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65095
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65095
- OSV: https://osv.dev/vulnerability/CVE-2025-65095

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65095/
Summaries are generated and may contain mistakes; the official description above is the record.
