# CVE-2025-65098: Typebot Vulnerable to Credential Theft via Client-Side Script Execution and API Authorization Bypass

> Attackers can steal user credentials via malicious script execution and API authorization bypass in Typebot chatbot builder.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-4xc5-wfwc-jw47

## What is CVE-2025-65098?

CVE-2025-65098 is a high-severity cross-site scripting vulnerability in baptisteArno typebot.io, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Typebot is an open-source chatbot builder. In versions prior to 3.13.2, client-side script execution in Typebot allows stealing all stored credentials from any user. When a victim previews a malicious typebot by clicking "Run", JavaScript executes in their browser and exfiltrates their OpenAI keys, Google Sheets tokens, and SMTP passwords. The `/api/trpc/credentials.getCredentials` endpoint returns plaintext API keys without verifying credential ownership. Version 3.13.2 fixes the issue.

Weakness: CWE-862 (Missing Authorization), CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-522 (Insufficiently Protected Credentials), CWE-311 (Missing Encryption of Sensitive Data), CWE-284 (Improper Access Control), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-65098?

2 open source packages ship an affected version, including @typebot.io/js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@typebot.io/js` | npm | All versions | 0.9.15 |
| `@typebot.io/js` | npm | All versions | 0.9.15 |

Products: Typebot Typebot.

## How do I fix CVE-2025-65098?

Upgrade @typebot.io/js to 0.9.15 or later.

## Is CVE-2025-65098 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65098 exists.

## Other vulnerabilities in baptisteArno typebot.io

- [CVE-2025-64709](https://insights.sbomify.com/CVE-2025-64709/): Typebot May Expose AWS EKS Credentials via Server Side Request Forgery in Webhook Block (critical 9.6)
- [CVE-2024-30264](https://insights.sbomify.com/CVE-2024-30264/): typebot.io: `GHSL-2024-040` (high 8.1)
- [CVE-2025-64706](https://insights.sbomify.com/CVE-2025-64706/): Typebot IDOR Vulnerability: Unauthorized API Token Deletion and Exposure (medium 5.0)
- [CVE-2021-24902](https://insights.sbomify.com/CVE-2021-24902/): Typebot < 1.4.3 - Admin+ Stored Cross Site Scripting (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65098 and fix it if it is affected.

What it is: CVE-2025-65098 is a high-severity cross-site scripting vulnerability in baptisteArno typebot.io, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65098 exists.

Affected packages and fixed versions:
- @typebot.io/js (npm): affected all versions; fixed in 0.9.15
- @typebot.io/js (npm): affected all versions; fixed in 0.9.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65098/ (Markdown: https://insights.sbomify.com/CVE-2025-65098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65098
- OSV: https://osv.dev/vulnerability/CVE-2025-65098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65098/
Summaries are generated and may contain mistakes; the official description above is the record.
