CVE-2025-65099 Claude Code vulnerable to command execution prior to startup trust dialog

High 7.7 Published Updated

Attackers can execute arbitrary code via Yarn plugins before the trust dialog appears if users run the tool in untrusted directories.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-65099?

CVE-2025-65099 is a high-severity command injection vulnerability in anthropics claude-code, published on 19 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Claude Code is an agentic coding tool. Prior to version 1.0.39, when running on a machine with Yarn 3.0 or above, Claude Code could have been tricked to execute code contained in a project via yarn plugins before the user accepted the startup trust dialog. Exploiting this would have required a user to start Claude Code in an untrusted directory and to be using Yarn 3.0 or above. This issue has been patched in version 1.0.39.

Weakness: CWE-94

Which versions are affected by CVE-2025-65099?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.

PackageAffectedFixed in
@anthropic-ai/claude-code npmAll versions1.0.39
@anthropic-ai/claude-code npmAll versions1.0.39

Products include Anthropic Claude Code.

How do I fix CVE-2025-65099?

Upgrade @anthropic-ai/claude-code to 1.0.39 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-65099 being exploited?

There is no known exploitation of CVE-2025-65099 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-5hhx-v7f6-x7gv.

Is CVE-2025-65099 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free