{"answers":{"affected":"2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-65099 in the wild and no public exploit code.","fix":"Upgrade @anthropic-ai/claude-code to 1.0.39 or later.","what":"CVE-2025-65099 is a high-severity command injection vulnerability in anthropics claude-code, published on 19 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-65099 and fix it if it is affected.\n\nWhat it is: CVE-2025-65099 is a high-severity command injection vulnerability in anthropics claude-code, published on 19 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-65099 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.39\n- @anthropic-ai/claude-code (npm): affected all versions; fixed in 1.0.39\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65099/ (Markdown: https://insights.sbomify.com/CVE-2025-65099/index.md)","id":"CVE-2025-65099","markdown":"https://insights.sbomify.com/CVE-2025-65099/index.md","name":"CVE-2025-65099","record":{"aliases":["GHSA-5hhx-v7f6-x7gv"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Claude Code CLI","requires_auth":"none","summary":"Attackers can execute arbitrary code via Yarn plugins before the trust dialog appears if users run the tool in untrusted directories.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"claude_code","vendor":"anthropic"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Claude Code is an agentic coding tool. Prior to version 1.0.39, when running on a machine with Yarn 3.0 or above, Claude Code could have been tricked to execute code contained in a project via yarn plugins before the user accepted the startup trust dialog. Exploiting this would have required a user to start Claude Code in an untrusted directory and to be using Yarn 3.0 or above. This issue has been patched in version 1.0.39.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2025-06-29","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-06-29T20:46:18Z","kind":"github_poc","ref":"https://github.com/b-faller/cve-2025-65099","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Claude Code vulnerable to command execution prior to startup trust dialog","id":"CVE-2025-65099","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Security Snapshot May Use Unintended Timestamp When Only ISAR_APT_SNAPSHOT_DATE Is Set","id":"CVE-2025-65100"},"packages":[{"ecosystem":"npm","fixed":["1.0.39"],"introduced":["0"],"last_affected":[],"package":"@anthropic-ai/claude-code","purl":null,"source":"GHSA-5hhx-v7f6-x7gv"},{"ecosystem":"npm","fixed":["1.0.39"],"introduced":["0"],"last_affected":[],"package":"@anthropic-ai/claude-code","purl":"pkg:npm/%40anthropic-ai/claude-code","source":"GHSA-5hhx-v7f6-x7gv"}],"prev":{"headline":"Typebot Vulnerable to Credential Theft via Client-Side Script Execution and API Authorization Bypass","id":"CVE-2025-65098"},"products":["claude-code"],"published":"2025-11-19","related":[{"cvss_score":8.7,"headline":"Claude Code Command Validation Bypass Allows Arbitrary Code Execution","id":"CVE-2025-66032","kev_date_added":null,"published":"2025-12-03"},{"cvss_score":8.7,"headline":"@anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes","id":"CVE-2025-64755","kev_date_added":null,"published":"2025-11-21"},{"cvss_score":8.7,"headline":"Claude Code's startup trust dialog could lead to Command Execution attack","id":"CVE-2025-59536","kev_date_added":null,"published":"2025-10-03"},{"cvss_score":8.7,"headline":"Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution","id":"CVE-2025-58764","kev_date_added":null,"published":"2025-09-10"},{"cvss_score":8.7,"headline":"Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email","id":"CVE-2025-59041","kev_date_added":null,"published":"2025-09-10"},{"cvss_score":8.7,"headline":"Claude Code echo command allowed bypass of user approval prompt for command execution","id":"CVE-2025-54795","kev_date_added":null,"published":"2025-08-05"},{"cvss_score":7.7,"headline":"Claude Code: Sandbox Escape via Git Worktree Path Confusion Allows Unsandboxed Code Execution","id":"CVE-2026-55607","kev_date_added":null,"published":"2026-06-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-20","vendors":["anthropics"]},"summary":"Attackers can execute arbitrary code via Yarn plugins before the trust dialog appears if users run the tool in untrusted directories.","url":"https://insights.sbomify.com/CVE-2025-65099/"}