{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-65102 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-65102 is a high-severity memory corruption vulnerability in pjsip pjproject, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-65102 and fix it if it is affected.\n\nWhat it is: CVE-2025-65102 is a high-severity memory corruption vulnerability in pjsip pjproject, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-65102 in the wild and no public exploit code.\n\nAffected product: pjsip pjproject. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65102/ (Markdown: https://insights.sbomify.com/CVE-2025-65102/index.md)","id":"CVE-2025-65102","markdown":"https://insights.sbomify.com/CVE-2025-65102/index.md","name":"CVE-2025-65102","record":{"aliases":["ALPINE-CVE-2025-65102","DEBIAN-CVE-2025-65102","GHSA-w5vr-39x7-h8g5","UBUNTU-CVE-2025-65102"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PJSIP multimedia library","requires_auth":"none","summary":"A buffer overflow in PJSIP's Opus PLC handling can cause unexpected application termination, affecting users receiving Opus audio.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"PJSIP is a free and open source multimedia communication library. Prior to version 2.16, Opus PLC may zero-fill the input frame as long as the decoder ptime, while the input frame length, which is based on stream ptime, may be less than that. This issue affects PJSIP users who use the Opus audio codec in receiving direction. The vulnerability can lead to unexpected application termination due to a memory overwrite. This issue has been patched in version 2.16.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PJSIP is vulnerable to buffer overflow in Opus PLC","id":"CVE-2025-65102","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"OpenSTAManager has an authenticated SQL Injection vulnerability in API via 'display' parameter","id":"CVE-2025-65103"},"packages":[],"prev":{"headline":"Security Snapshot May Use Unintended Timestamp When Only ISAR_APT_SNAPSHOT_DATE Is Set","id":"CVE-2025-65100"},"products":["pjproject"],"published":"2025-11-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-21","vendors":["pjsip"]},"summary":"A buffer overflow in PJSIP's Opus PLC handling can cause unexpected application termination, affecting users receiving Opus audio.","url":"https://insights.sbomify.com/CVE-2025-65102/"}