# CVE-2025-65102: PJSIP is vulnerable to buffer overflow in Opus PLC

> A buffer overflow in PJSIP's Opus PLC handling can cause unexpected application termination, affecting users receiving Opus audio.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2025
- **Updated:** 21 Nov 2025
- **Also known as:** ALPINE-CVE-2025-65102, DEBIAN-CVE-2025-65102, GHSA-w5vr-39x7-h8g5, UBUNTU-CVE-2025-65102

## What is CVE-2025-65102?

CVE-2025-65102 is a high-severity memory corruption vulnerability in pjsip pjproject, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PJSIP is a free and open source multimedia communication library. Prior to version 2.16, Opus PLC may zero-fill the input frame as long as the decoder ptime, while the input frame length, which is based on stream ptime, may be less than that. This issue affects PJSIP users who use the Opus audio codec in receiving direction. The vulnerability can lead to unexpected application termination due to a memory overwrite. This issue has been patched in version 2.16.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2025-65102?


## How do I fix CVE-2025-65102?

Upgrade to a fixed version.

## Is CVE-2025-65102 being exploited?

There is no known exploitation of CVE-2025-65102 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65102 and fix it if it is affected.

What it is: CVE-2025-65102 is a high-severity memory corruption vulnerability in pjsip pjproject, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65102 in the wild and no public exploit code.

Affected product: pjsip pjproject. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65102/ (Markdown: https://insights.sbomify.com/CVE-2025-65102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65102
- OSV: https://osv.dev/vulnerability/CVE-2025-65102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65102/
Summaries are generated and may contain mistakes; the official description above is the record.
