{"answers":{"affected":"2 open source packages ship an affected version, including devcode-it/openstamanager.","exploited":"There is no known exploitation of CVE-2025-65103 in the wild and no public exploit code.","fix":"Upgrade devcode-it/openstamanager to 2.9.5 or later.","what":"CVE-2025-65103 is a high-severity SQL injection vulnerability in devcode-it openstamanager, published on 19 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-65103 and fix it if it is affected.\n\nWhat it is: CVE-2025-65103 is a high-severity SQL injection vulnerability in devcode-it openstamanager, published on 19 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-65103 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- devcode-it/openstamanager (Packagist): affected all versions; fixed in 2.9.5\n- devcode-it/openstamanager (Packagist): affected all versions; fixed in 2.9.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65103/ (Markdown: https://insights.sbomify.com/CVE-2025-65103/index.md)","id":"CVE-2025-65103","markdown":"https://insights.sbomify.com/CVE-2025-65103/index.md","name":"CVE-2025-65103","record":{"aliases":["GHSA-2jm2-2p35-rp3j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenSTAManager","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary SQL queries via the display parameter to read, modify, or delete database data.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"OpenSTAManager is an open source management software for technical assistance and invoicing. Prior to version 2.9.5, an authenticated SQL Injection vulnerability in the API allows any user, regardless of permission level, to execute arbitrary SQL queries. By manipulating the display parameter in an API request, an attacker can exfiltrate, modify, or delete any data in the database, leading to a full system compromise. This issue has been patched in version 2.9.5.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenSTAManager has an authenticated SQL Injection vulnerability in API via 'display' parameter","id":"CVE-2025-65103","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Firebird: Information leak vulnerability in firebird3 client when used with newer server","id":"CVE-2025-65104"},"packages":[{"ecosystem":"Packagist","fixed":["2.9.5"],"introduced":["0"],"last_affected":[],"package":"devcode-it/openstamanager","purl":null,"source":"GHSA-2jm2-2p35-rp3j"},{"ecosystem":"Packagist","fixed":["2.9.5"],"introduced":["0"],"last_affected":[],"package":"devcode-it/openstamanager","purl":"pkg:composer/devcode-it/openstamanager","source":"GHSA-2jm2-2p35-rp3j"}],"prev":{"headline":"PJSIP is vulnerable to buffer overflow in Opus PLC","id":"CVE-2025-65102"},"products":["openstamanager"],"published":"2025-11-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-19","vendors":["devcode-it"]},"summary":"Authenticated attackers can execute arbitrary SQL queries via the display parameter to read, modify, or delete database data.","url":"https://insights.sbomify.com/CVE-2025-65103/"}