# CVE-2025-65103: OpenSTAManager has an authenticated SQL Injection vulnerability in API via 'display' parameter

> Authenticated attackers can execute arbitrary SQL queries via the display parameter to read, modify, or delete database data.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2025
- **Updated:** 19 Nov 2025
- **Also known as:** GHSA-2jm2-2p35-rp3j

## What is CVE-2025-65103?

CVE-2025-65103 is a high-severity SQL injection vulnerability in devcode-it openstamanager, published on 19 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenSTAManager is an open source management software for technical assistance and invoicing. Prior to version 2.9.5, an authenticated SQL Injection vulnerability in the API allows any user, regardless of permission level, to execute arbitrary SQL queries. By manipulating the display parameter in an API request, an attacker can exfiltrate, modify, or delete any data in the database, leading to a full system compromise. This issue has been patched in version 2.9.5.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-65103?

2 open source packages ship an affected version, including devcode-it/openstamanager.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devcode-it/openstamanager` | Packagist | All versions | 2.9.5 |
| `devcode-it/openstamanager` | Packagist | All versions | 2.9.5 |

## How do I fix CVE-2025-65103?

Upgrade devcode-it/openstamanager to 2.9.5 or later.

## Is CVE-2025-65103 being exploited?

There is no known exploitation of CVE-2025-65103 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65103 and fix it if it is affected.

What it is: CVE-2025-65103 is a high-severity SQL injection vulnerability in devcode-it openstamanager, published on 19 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65103 in the wild and no public exploit code.

Affected packages and fixed versions:
- devcode-it/openstamanager (Packagist): affected all versions; fixed in 2.9.5
- devcode-it/openstamanager (Packagist): affected all versions; fixed in 2.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65103/ (Markdown: https://insights.sbomify.com/CVE-2025-65103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65103
- OSV: https://osv.dev/vulnerability/CVE-2025-65103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65103/
Summaries are generated and may contain mistakes; the official description above is the record.
