{"answers":{"affected":"3 open source packages ship an affected version, including github.com/apptainer/apptainer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-65105 in the wild and no public exploit code.","fix":"Upgrade github.com/apptainer/apptainer to 1.4.5 or later.","what":"CVE-2025-65105 is a medium-severity vulnerability in apptainer, published on 2 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-65105 and fix it if it is affected.\n\nWhat it is: CVE-2025-65105 is a medium-severity vulnerability in apptainer, published on 2 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-65105 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.4.5\n- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.4.5\n- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.4.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65105/ (Markdown: https://insights.sbomify.com/CVE-2025-65105/index.md)","id":"CVE-2025-65105","markdown":"https://insights.sbomify.com/CVE-2025-65105/index.md","name":"CVE-2025-65105","record":{"aliases":["GHSA-j3rw-fx6g-q46j","GO-2025-4176","UBUNTU-CVE-2025-65105"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Apptainer container platform","requires_auth":"none","summary":"Attackers can bypass AppArmor and SELinux security restrictions in Apptainer containers, allowing unauthorized operations despite intended security profiles.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apptainer","vendor":"lfprojects"}],"cvss":{"score":4.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-706","name":"Use of Incorrectly-Resolved Name or Reference"},{"id":"CWE-61","name":"UNIX Symbolic Link (Symlink) Following"}],"description":"Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor:\u003cprofile\u003e and --security=selinux:\u003clabel\u003e which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apptainer ineffective application of selinux and apparmor --security options","id":"CVE-2025-65105","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":3,"n_references":6,"next":{"headline":"LangChain Vulnerable to Template Injection via Attribute Access in Prompt Templates","id":"CVE-2025-65106"},"packages":[{"ecosystem":"Go","fixed":["1.4.5"],"introduced":["0"],"last_affected":[],"package":"github.com/apptainer/apptainer","purl":null,"source":"GHSA-j3rw-fx6g-q46j"},{"ecosystem":"Go","fixed":["1.4.5"],"introduced":["0"],"last_affected":[],"package":"github.com/apptainer/apptainer","purl":"pkg:golang/github.com/apptainer/apptainer","source":"GHSA-j3rw-fx6g-q46j"},{"ecosystem":"Go","fixed":["1.4.5"],"introduced":["0"],"last_affected":[],"package":"github.com/apptainer/apptainer","purl":"pkg:golang/github.com/apptainer/apptainer","source":"GO-2025-4176"}],"prev":{"headline":"Firebird: Information leak vulnerability in firebird3 client when used with newer server","id":"CVE-2025-65104"},"products":["apptainer"],"published":"2025-12-02","related":[{"cvss_score":7.1,"headline":"Unpatched extfs vulnerabilities are exploitable through suid-mode Apptainer","id":"CVE-2023-30549","kev_date_added":null,"published":"2023-04-25"},{"cvss_score":6.1,"headline":"Apptainer's ineffective privileges drop when requesting container network","id":"CVE-2023-38496","kev_date_added":null,"published":"2023-07-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-02","vendors":["apptainer"]},"summary":"Attackers can bypass AppArmor and SELinux security restrictions in Apptainer containers, allowing unauthorized operations despite intended security profiles.","url":"https://insights.sbomify.com/CVE-2025-65105/"}