# CVE-2025-65105: Apptainer ineffective application of selinux and apparmor --security options

> Attackers can bypass AppArmor and SELinux security restrictions in Apptainer containers, allowing unauthorized operations despite intended security profiles.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-j3rw-fx6g-q46j, GO-2025-4176, UBUNTU-CVE-2025-65105

## What is CVE-2025-65105?

CVE-2025-65105 is a medium-severity vulnerability in apptainer, published on 2 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor:<profile> and --security=selinux:<label> which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference), CWE-61 (UNIX Symbolic Link (Symlink) Following)

## Which versions are affected by CVE-2025-65105?

3 open source packages ship an affected version, including github.com/apptainer/apptainer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apptainer/apptainer` | Go | All versions | 1.4.5 |
| `github.com/apptainer/apptainer` | Go | All versions | 1.4.5 |
| `github.com/apptainer/apptainer` | Go | All versions | 1.4.5 |

Products: Lfprojects Apptainer.

## How do I fix CVE-2025-65105?

Upgrade github.com/apptainer/apptainer to 1.4.5 or later.

## Is CVE-2025-65105 being exploited?

There is no known exploitation of CVE-2025-65105 in the wild and no public exploit code.

## Other vulnerabilities in apptainer

- [CVE-2023-30549](https://insights.sbomify.com/CVE-2023-30549/): Unpatched extfs vulnerabilities are exploitable through suid-mode Apptainer (high 7.1)
- [CVE-2023-38496](https://insights.sbomify.com/CVE-2023-38496/): Apptainer's ineffective privileges drop when requesting container network (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65105 and fix it if it is affected.

What it is: CVE-2025-65105 is a medium-severity vulnerability in apptainer, published on 2 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-65105 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.4.5
- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.4.5
- github.com/apptainer/apptainer (Go): affected all versions; fixed in 1.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65105/ (Markdown: https://insights.sbomify.com/CVE-2025-65105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65105
- OSV: https://osv.dev/vulnerability/CVE-2025-65105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65105/
Summaries are generated and may contain mistakes; the official description above is the record.
