CVE-2025-65107 Langfuse SSO Account Takeover via CSRF or phishing attack
Attackers can take over user accounts via CSRF or phishing if SSO provider checks are not explicitly configured in Langfuse.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2025-65107?
CVE-2025-65107 is a medium-severity vulnerability in langfuse, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_<PROVIDER>_CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2.95.12 and 3.131.0. A workaround for this issue involves setting AUTH_<PROVIDER>_CHECK.
Which versions are affected by CVE-2025-65107?
It affects 1 product.
Products include Langfuse Langfuse.
How do I fix CVE-2025-65107?
No fix has been published for CVE-2025-65107 yet. Limit exposure of the affected software until one is available.
Is CVE-2025-65107 being exploited?
There is no known exploitation of CVE-2025-65107 in the wild and no public exploit code.
Other vulnerabilities in langfuse
- CVE-2025-59305 Missing authorization in n/a
- CVE-2026-24055 Langfuse Slack OAuth Installation Endpoint Lacks Authentication, Enabling Arbitrary Project Linking
- CVE-2026-41487 Missing authorization in langfuse
- CVE-2025-64504 Langfuse vulnerable to cross‑organization enumeration of member & invitation lists via project membership APIs
- CVE-2025-9799 Langfuse Webhook promptRouter.ts promptChangeEventSourcing server-side request forgery
Sources
Also known as GHSA-w9pw-c549-5m6w.