{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-65107 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-65107 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-65107 is a medium-severity vulnerability in langfuse, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-65107 and fix it if it is affected.\n\nWhat it is: CVE-2025-65107 is a medium-severity vulnerability in langfuse, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-65107 in the wild and no public exploit code.\n\nAffected product: langfuse. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65107/ (Markdown: https://insights.sbomify.com/CVE-2025-65107/index.md)","id":"CVE-2025-65107","markdown":"https://insights.sbomify.com/CVE-2025-65107/index.md","name":"CVE-2025-65107","record":{"aliases":["GHSA-w9pw-c549-5m6w"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"LLM engineering platform","requires_auth":"none","summary":"Attackers can take over user accounts via CSRF or phishing if SSO provider checks are not explicitly configured in Langfuse.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"langfuse","vendor":"langfuse"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_\u003cPROVIDER\u003e_CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2.95.12 and 3.131.0. A workaround for this issue involves setting AUTH_\u003cPROVIDER\u003e_CHECK.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Langfuse SSO Account Takeover via CSRF or phishing attack","id":"CVE-2025-65107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"md-to-pdf is vulnerable to arbitrary JavaScript code execution when parsing front matter","id":"CVE-2025-65108"},"packages":[],"prev":{"headline":"LangChain Vulnerable to Template Injection via Attribute Access in Prompt Templates","id":"CVE-2025-65106"},"products":["langfuse"],"published":"2025-11-21","related":[{"cvss_score":7.6,"headline":"Missing authorization in n/a","id":"CVE-2025-59305","kev_date_added":null,"published":"2025-09-24"},{"cvss_score":6.3,"headline":"Langfuse Slack OAuth Installation Endpoint Lacks Authentication, Enabling Arbitrary Project Linking","id":"CVE-2026-24055","kev_date_added":null,"published":"2026-01-22"},{"cvss_score":5.3,"headline":"Missing authorization in langfuse","id":"CVE-2026-41487","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":5,"headline":"Langfuse vulnerable to cross‑organization enumeration of member \u0026 invitation lists via project membership APIs","id":"CVE-2025-64504","kev_date_added":null,"published":"2025-11-10"},{"cvss_score":2.3,"headline":"Langfuse Webhook promptRouter.ts promptChangeEventSourcing server-side request forgery","id":"CVE-2025-9799","kev_date_added":null,"published":"2025-09-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-24","vendors":["langfuse"]},"summary":"Attackers can take over user accounts via CSRF or phishing if SSO provider checks are not explicitly configured in Langfuse.","url":"https://insights.sbomify.com/CVE-2025-65107/"}