# CVE-2025-65108: md-to-pdf is vulnerable to arbitrary JavaScript code execution when parsing front matter

> Attackers can execute arbitrary code by crafting malicious Markdown front matter, affecting users of the md-to-pdf library.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2025
- **Updated:** 24 Nov 2025
- **Also known as:** GHSA-547r-qmjm-8hvw

## What is CVE-2025-65108?

CVE-2025-65108 is a critical code injection vulnerability in simonhaenisch md-to-pdf, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

md-to-pdf is a CLI tool for converting Markdown files to PDF using Node.js and headless Chrome. Prior to version 5.2.5, a Markdown front-matter block that contains JavaScript delimiter causes the JS engine in gray-matter library to execute arbitrary code in the Markdown to PDF converter process of md-to-pdf library, resulting in remote code execution. This issue has been patched in version 5.2.5.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-65108?

2 open source packages ship an affected version, including md-to-pdf.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `md-to-pdf` | npm | All versions | 5.2.5 |
| `md-to-pdf` | npm | All versions | 5.2.5 |

## How do I fix CVE-2025-65108?

Upgrade md-to-pdf to 5.2.5 or later.

## Is CVE-2025-65108 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65108 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65108 and fix it if it is affected.

What it is: CVE-2025-65108 is a critical code injection vulnerability in simonhaenisch md-to-pdf, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65108 exists.

Affected packages and fixed versions:
- md-to-pdf (npm): affected all versions; fixed in 5.2.5
- md-to-pdf (npm): affected all versions; fixed in 5.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65108/ (Markdown: https://insights.sbomify.com/CVE-2025-65108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65108
- OSV: https://osv.dev/vulnerability/CVE-2025-65108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65108/
Summaries are generated and may contain mistakes; the official description above is the record.
