# CVE-2025-65109: Minder does not sandbox http.send in Rego programs

> Attackers can exploit unsandboxed HTTP requests in Rego programs to access internal resources via the Minder server.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:L/SC:H/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2025
- **Updated:** 24 Nov 2025
- **Also known as:** GHSA-6xvf-4vh9-mw47, GO-2025-4147

## What is CVE-2025-65109?

CVE-2025-65109 is a high-severity server-side request forgery vulnerability in mindersec minder, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Minder is an open source software supply chain security platform. In Minder Helm version 0.20241106.3386+ref.2507dbf and Minder Go versions from 0.0.72 to 0.0.83, Minder users may fetch content in the context of the Minder server, which may include URLs which the user would not normally have access to. This issue has been patched in Minder Helm version 0.20250203.3849+ref.fdc94f0 and Minder Go version 0.0.84.

Weakness: CWE-830 (Inclusion of Web Functionality from an Untrusted Source)

## Which versions are affected by CVE-2025-65109?

3 open source packages ship an affected version, including github.com/mindersec/minder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mindersec/minder` | Go | From 0.0.72 | 0.0.84 |
| `github.com/mindersec/minder` | Go | From 0.0.72 | 0.0.84 |
| `github.com/mindersec/minder` | Go | From 0.0.72 | 0.0.84 |

## How do I fix CVE-2025-65109?

Upgrade github.com/mindersec/minder to 0.0.84 or later.

## Is CVE-2025-65109 being exploited?

There is no known exploitation of CVE-2025-65109 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65109 and fix it if it is affected.

What it is: CVE-2025-65109 is a high-severity server-side request forgery vulnerability in mindersec minder, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65109 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mindersec/minder (Go): affected from 0.0.72; fixed in 0.0.84
- github.com/mindersec/minder (Go): affected from 0.0.72; fixed in 0.0.84
- github.com/mindersec/minder (Go): affected from 0.0.72; fixed in 0.0.84

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65109/ (Markdown: https://insights.sbomify.com/CVE-2025-65109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65109
- OSV: https://osv.dev/vulnerability/CVE-2025-65109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65109/
Summaries are generated and may contain mistakes; the official description above is the record.
