CVE-2025-65110 Vega XSS via expression abusing vlSelectionTuples function array map calls in environments with satisfactory function gadgets in the global scope
Attackers can execute arbitrary JavaScript via malicious Vega specifications if the library is exposed globally, compromising user data and application integrity.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-65110?
CVE-2025-65110 is a high-severity cross-site scripting vulnerability in vega, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Prior to versions 6.1.2 and 5.6.3, applications meeting two conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. First, they use `vega` in an application that attaches both `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window`, or has any other satisfactory function gadgets in the global scope. Second, they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). This vulnerability allows for DOM XSS, potentially stored, potentially reflected, depending on how the library is being used. The vulnerability requires user interaction with the page to trigger. An attacker can exploit this issue by tricking a user into opening a malicious Vega specification. Successful exploitation allows the attacker to execute arbitrary JavaScript in the context of the application’s domain. This can lead to theft of sensitive information such as authentication tokens, manipulation of data displayed to the user, or execution of unauthorized actions on behalf of the victim. This exploit compromises confidentiality and integrity of impacted applications.Patched versions are available in `[email protected]` (requires ESM) for Vega v6 and `[email protected]` (no ESM needed) for Vega v5. As a workaround, do not attach `vega` or `vega.View` instances to global variables or the window as the editor used to do. This is a development-only debugging practice that should not be used in any situation where Vega/Vega-lite definitions can come from untrusted parties.
Weakness: CWE-79
Which versions are affected by CVE-2025-65110?
4 open source packages ship an affected version, including vega-selections. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
vega-selections npm | All versions | 5.6.3 |
vega-selections npm | All versions | 5.6.3 |
vega-selections npm | From 6.0.0 | 6.1.2 |
vega-selections npm | From 6.0.0 | 6.1.2 |
Products include Vega Project Vega.
How do I fix CVE-2025-65110?
Upgrade vega-selections to a fixed version for your release line: 5.6.3 or 6.1.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-65110 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65110 exists.
Other vulnerabilities in vega
Sources
Also known as DEBIAN-CVE-2025-65110, GHSA-829q-m3qg-ph8r, UBUNTU-CVE-2025-65110.