{"answers":{"affected":"4 open source packages ship an affected version, including vega-selections. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65110 exists.","fix":"Upgrade vega-selections to a fixed version for your release line: 5.6.3 or 6.1.2.","what":"CVE-2025-65110 is a high-severity cross-site scripting vulnerability in vega, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-65110 and fix it if it is affected.\n\nWhat it is: CVE-2025-65110 is a high-severity cross-site scripting vulnerability in vega, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65110 exists.\n\nAffected packages and fixed versions:\n- vega-selections (npm): affected all versions; fixed in 5.6.3\n- vega-selections (npm): affected all versions; fixed in 5.6.3\n- vega-selections (npm): affected from 6.0.0; fixed in 6.1.2\n- vega-selections (npm): affected from 6.0.0; fixed in 6.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-65110/ (Markdown: https://insights.sbomify.com/CVE-2025-65110/index.md)","id":"CVE-2025-65110","markdown":"https://insights.sbomify.com/CVE-2025-65110/index.md","name":"CVE-2025-65110","record":{"aliases":["DEBIAN-CVE-2025-65110","GHSA-829q-m3qg-ph8r","UBUNTU-CVE-2025-65110"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Vega visualization library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via malicious Vega specifications if the library is exposed globally, compromising user data and application integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vega","vendor":"vega_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Prior to versions 6.1.2 and 5.6.3, applications meeting two conditions are at risk of arbitrary JavaScript code execution, even if \"safe mode\" expressionInterpreter is used. First, they use `vega` in an application that attaches both `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window`, or has any other satisfactory function gadgets in the global scope. Second, they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). This vulnerability allows for DOM XSS, potentially stored, potentially reflected, depending on how the library is being used. The vulnerability requires user interaction with the page to trigger. An attacker can exploit this issue by tricking a user into opening a malicious Vega specification. Successful exploitation allows the attacker to execute arbitrary JavaScript in the context of the application’s domain. This can lead to theft of sensitive information such as authentication tokens, manipulation of data displayed to the user, or execution of unauthorized actions on behalf of the victim. This exploit compromises confidentiality and integrity of impacted applications.Patched versions are available in `vega-selections@6.1.2` (requires ESM) for Vega v6 and `vega-selections@5.6.3` (no ESM needed) for Vega v5. As a workaround, do not attach `vega` or `vega.View` instances to global variables or the window as the editor used to do. This is a development-only debugging practice that should not be used in any situation where Vega/Vega-lite definitions can come from untrusted parties.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Vega XSS via expression abusing vlSelectionTuples function array map calls in environments with satisfactory function gadgets in the global scope","id":"CVE-2025-65110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":4,"n_references":1,"next":{"headline":"SpiceDB's LookupResources with Multiple Entrypoints across Different Definitions Can Return Incomplete Results","id":"CVE-2025-65111"},"packages":[{"ecosystem":"npm","fixed":["5.6.3"],"introduced":["0"],"last_affected":[],"package":"vega-selections","purl":null,"source":"GHSA-829q-m3qg-ph8r"},{"ecosystem":"npm","fixed":["5.6.3"],"introduced":["0"],"last_affected":[],"package":"vega-selections","purl":"pkg:npm/vega-selections","source":"GHSA-829q-m3qg-ph8r"},{"ecosystem":"npm","fixed":["6.1.2"],"introduced":["6.0.0"],"last_affected":[],"package":"vega-selections","purl":null,"source":"GHSA-829q-m3qg-ph8r"},{"ecosystem":"npm","fixed":["6.1.2"],"introduced":["6.0.0"],"last_affected":[],"package":"vega-selections","purl":"pkg:npm/vega-selections","source":"GHSA-829q-m3qg-ph8r"}],"prev":{"headline":"Minder does not sandbox http.send in Rego programs","id":"CVE-2025-65109"},"products":["vega"],"published":"2026-01-05","related":[{"cvss_score":8.7,"headline":"XSS in Vega","id":"CVE-2020-26296","kev_date_added":null,"published":"2020-12-30"},{"cvss_score":4.3,"headline":"Improperly Controlled Modification of Dynamically-Determined Object Attributes in vega-util","id":"CVE-2019-10806","kev_date_added":null,"published":"2020-03-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-05","vendors":["vega"]},"summary":"Attackers can execute arbitrary JavaScript via malicious Vega specifications if the library is exposed globally, compromising user data and application integrity.","url":"https://insights.sbomify.com/CVE-2025-65110/"}