# CVE-2025-65110: Vega XSS via expression abusing vlSelectionTuples function array map calls in environments with satisfactory function gadgets in the global scope

> Attackers can execute arbitrary JavaScript via malicious Vega specifications if the library is exposed globally, compromising user data and application integrity.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jan 2026
- **Updated:** 5 Jan 2026
- **Also known as:** DEBIAN-CVE-2025-65110, GHSA-829q-m3qg-ph8r, UBUNTU-CVE-2025-65110

## What is CVE-2025-65110?

CVE-2025-65110 is a high-severity cross-site scripting vulnerability in vega, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Prior to versions 6.1.2 and 5.6.3, applications meeting two conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. First, they use `vega` in an application that attaches both `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window`, or has any other satisfactory function gadgets in the global scope. Second, they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). This vulnerability allows for DOM XSS, potentially stored, potentially reflected, depending on how the library is being used. The vulnerability requires user interaction with the page to trigger. An attacker can exploit this issue by tricking a user into opening a malicious Vega specification. Successful exploitation allows the attacker to execute arbitrary JavaScript in the context of the application’s domain. This can lead to theft of sensitive information such as authentication tokens, manipulation of data displayed to the user, or execution of unauthorized actions on behalf of the victim. This exploit compromises confidentiality and integrity of impacted applications.Patched versions are available in `vega-selections@6.1.2` (requires ESM) for Vega v6 and `vega-selections@5.6.3` (no ESM needed) for Vega v5. As a workaround, do not attach `vega` or `vega.View` instances to global variables or the window as the editor used to do. This is a development-only debugging practice that should not be used in any situation where Vega/Vega-lite definitions can come from untrusted parties.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-65110?

4 open source packages ship an affected version, including vega-selections. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vega-selections` | npm | All versions | 5.6.3 |
| `vega-selections` | npm | All versions | 5.6.3 |
| `vega-selections` | npm | From 6.0.0 | 6.1.2 |
| `vega-selections` | npm | From 6.0.0 | 6.1.2 |

Products: Vega Project Vega.

## How do I fix CVE-2025-65110?

Upgrade vega-selections to a fixed version for your release line: 5.6.3 or 6.1.2.

## Is CVE-2025-65110 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65110 exists.

## Other vulnerabilities in vega

- [CVE-2020-26296](https://insights.sbomify.com/CVE-2020-26296/): XSS in Vega (high 8.7)
- [CVE-2019-10806](https://insights.sbomify.com/CVE-2019-10806/): Improperly Controlled Modification of Dynamically-Determined Object Attributes in vega-util (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65110 and fix it if it is affected.

What it is: CVE-2025-65110 is a high-severity cross-site scripting vulnerability in vega, published on 5 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65110 exists.

Affected packages and fixed versions:
- vega-selections (npm): affected all versions; fixed in 5.6.3
- vega-selections (npm): affected all versions; fixed in 5.6.3
- vega-selections (npm): affected from 6.0.0; fixed in 6.1.2
- vega-selections (npm): affected from 6.0.0; fixed in 6.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65110/ (Markdown: https://insights.sbomify.com/CVE-2025-65110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65110
- OSV: https://osv.dev/vulnerability/CVE-2025-65110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65110/
Summaries are generated and may contain mistakes; the official description above is the record.
