# CVE-2025-65111: SpiceDB's LookupResources with Multiple Entrypoints across Different Definitions Can Return Incomplete Results

> SpiceDB may return incomplete permission results for specific union schemas, potentially allowing unauthorized access to resources.

- **Severity:** Low 2.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2025
- **Updated:** 24 Nov 2025
- **Also known as:** GHSA-9m7r-g8hg-x3vr, GO-2025-4151

## What is CVE-2025-65111?

CVE-2025-65111 is a low-severity vulnerability in authzed spicedb, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SpiceDB is an open source database system for creating and managing security-critical application permissions. Prior to version 1.47.1, if a schema includes the following characteristics: permission defined in terms of a union (+) and that union references the same relation on both sides (but one side arrows to a different permission). Then SpiceDB may have missing LookupResources results when checking the permission. This only affects LookupResources; other APIs calculate permissionship correctly. The issue is fixed in version 1.47.1.

Weakness: CWE-277 (Insecure Inherited Permissions)

## Which versions are affected by CVE-2025-65111?

3 open source packages ship an affected version, including github.com/authzed/spicedb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authzed/spicedb` | Go | All versions | 1.47.1 |
| `github.com/authzed/spicedb` | Go | All versions | 1.47.1 |
| `github.com/authzed/spicedb` | Go | All versions | 1.47.1 |

Products: Authzed Spicedb.

## How do I fix CVE-2025-65111?

Upgrade github.com/authzed/spicedb to 1.47.1 or later.

## Is CVE-2025-65111 being exploited?

There is no known exploitation of CVE-2025-65111 in the wild and no public exploit code.

## Other vulnerabilities in authzed spicedb

- [CVE-2023-29193](https://insights.sbomify.com/CVE-2023-29193/): SpiceDB binding metrics port to untrusted networks and can leak command-line flags (high 8.7)
- [CVE-2022-21646](https://insights.sbomify.com/CVE-2022-21646/): Lookup operations do not take into account wildcards in SpiceDB (high 8.1)
- [CVE-2024-27101](https://insights.sbomify.com/CVE-2024-27101/): Integer overflow in chunking helper causes dispatching to miss elements or panic (high 7.3)
- [CVE-2026-40091](https://insights.sbomify.com/CVE-2026-40091/): SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs (medium 6.0)
- [CVE-2023-46255](https://insights.sbomify.com/CVE-2023-46255/): `SPICEDB_DATASTORE_CONN_URI` is leaked when URI cannot be parsed (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65111 and fix it if it is affected.

What it is: CVE-2025-65111 is a low-severity vulnerability in authzed spicedb, published on 21 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65111 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.47.1
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.47.1
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.47.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65111/ (Markdown: https://insights.sbomify.com/CVE-2025-65111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65111
- OSV: https://osv.dev/vulnerability/CVE-2025-65111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65111/
Summaries are generated and may contain mistakes; the official description above is the record.
