CVE-2025-65114 Apache Traffic Server: Malformed chunked message body allows request smuggling
Attackers can exploit malformed chunked messages to perform request smuggling, potentially bypassing security controls or accessing unauthorized data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-65114?
CVE-2025-65114 is a high-severity vulnerability in Apache Traffic Server, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Traffic Server allows request smuggling if chunked messages are malformed.
This issue affects Apache Traffic Server: from 9.0.0 through 9.2.12, from 10.0.0 through 10.1.1.
Users are recommended to upgrade to version 9.2.13 or 10.1.2, which fix the issue.
Weakness: CWE-444
Which versions are affected by CVE-2025-65114?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2025-65114?
Upgrade to a fixed version.
Is CVE-2025-65114 being exploited?
There is no known exploitation of CVE-2025-65114 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2025-65114, GHSA-5vvj-6v57-2369, UBUNTU-CVE-2025-65114.