{"answers":{"affected":"2 open source packages ship an affected version, including mcp-remote.","exploited":"There is no known exploitation of CVE-2025-6514 in the wild and no public exploit code.","fix":"Upgrade mcp-remote to 0.1.16 or later.","what":"CVE-2025-6514 is a critical command injection vulnerability in mcp-remote, published on 9 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-6514 and fix it if it is affected.\n\nWhat it is: CVE-2025-6514 is a critical command injection vulnerability in mcp-remote, published on 9 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-6514 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mcp-remote (npm): affected from 0.0.5; fixed in 0.1.16\n- mcp-remote (npm): affected from 0.0.5; fixed in 0.1.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-6514/ (Markdown: https://insights.sbomify.com/CVE-2025-6514/index.md)","id":"CVE-2025-6514","markdown":"https://insights.sbomify.com/CVE-2025-6514/index.md","name":"CVE-2025-6514","record":{"aliases":["GHSA-6xpm-ggf7-wc3p"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MCP remote library","requires_auth":"none","summary":"Attackers can execute arbitrary OS commands by providing a malicious authorization endpoint URL to the mcp-remote library.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"JFROG","cpe":[],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"mcp-remote is exposed to OS command injection when connecting to untrusted MCP servers due to crafted input from the authorization_endpoint response URL","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2025-10-26","github_poc":1,"max_poc_stars":7,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-10-26T08:57:42Z","kind":"github_poc","ref":"https://github.com/Cyberency/CVE-2025-6514","stars":7,"title":"mcp-remote exposed to OS command injection"}],"tier":"poc_unverified"},"has_fix":true,"headline":"OS command injection in mcp-remote when connecting to untrusted MCP servers","id":"CVE-2025-6514","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Reuse of session IDs in oatpp-mcp leads to session hijacking and prompt hijacking by remote attackers","id":"CVE-2025-6515"},"packages":[{"ecosystem":"npm","fixed":["0.1.16"],"introduced":["0.0.5"],"last_affected":[],"package":"mcp-remote","purl":null,"source":"GHSA-6xpm-ggf7-wc3p"},{"ecosystem":"npm","fixed":["0.1.16"],"introduced":["0.0.5"],"last_affected":[],"package":"mcp-remote","purl":"pkg:npm/mcp-remote","source":"GHSA-6xpm-ggf7-wc3p"}],"prev":{"headline":"BRAIN2 Configuration file for database access not sufficiently secured","id":"CVE-2025-6513"},"products":[],"published":"2025-07-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-09","vendors":[]},"summary":"Attackers can execute arbitrary OS commands by providing a malicious authorization endpoint URL to the mcp-remote library.","url":"https://insights.sbomify.com/CVE-2025-6514/"}