# CVE-2025-6514: OS command injection in mcp-remote when connecting to untrusted MCP servers

> Attackers can execute arbitrary OS commands by providing a malicious authorization endpoint URL to the mcp-remote library.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jul 2025
- **Updated:** 9 Jul 2025
- **Also known as:** GHSA-6xpm-ggf7-wc3p

## What is CVE-2025-6514?

CVE-2025-6514 is a critical command injection vulnerability in mcp-remote, published on 9 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

mcp-remote is exposed to OS command injection when connecting to untrusted MCP servers due to crafted input from the authorization_endpoint response URL

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-6514?

2 open source packages ship an affected version, including mcp-remote.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-remote` | npm | From 0.0.5 | 0.1.16 |
| `mcp-remote` | npm | From 0.0.5 | 0.1.16 |

## How do I fix CVE-2025-6514?

Upgrade mcp-remote to 0.1.16 or later.

## Is CVE-2025-6514 being exploited?

There is no known exploitation of CVE-2025-6514 in the wild and no public exploit code.

Public exploit code:

- mcp-remote exposed to OS command injection (github_poc): https://github.com/Cyberency/CVE-2025-6514

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6514 and fix it if it is affected.

What it is: CVE-2025-6514 is a critical command injection vulnerability in mcp-remote, published on 9 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-6514 in the wild and no public exploit code.

Affected packages and fixed versions:
- mcp-remote (npm): affected from 0.0.5; fixed in 0.1.16
- mcp-remote (npm): affected from 0.0.5; fixed in 0.1.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6514/ (Markdown: https://insights.sbomify.com/CVE-2025-6514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6514
- OSV: https://osv.dev/vulnerability/CVE-2025-6514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6514/
Summaries are generated and may contain mistakes; the official description above is the record.
