# CVE-2025-65186: Grav CMS is vulnerable to Cross Site Scripting (XSS) in the page editor

> Authenticated users can inject stored XSS payloads via the Markdown editor, potentially compromising admin sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 2 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-cchq-397m-q2qm

## What is CVE-2025-65186?

CVE-2025-65186 is a medium-severity cross-site scripting vulnerability in Getgrav Grav, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Grav CMS 1.7.49 is vulnerable to Cross Site Scripting (XSS). The page editor allows authenticated users to edit page content via a Markdown editor. The editor fails to properly sanitize <script> tags, allowing stored XSS payloads to execute when pages are viewed in the admin interface.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-65186?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions to 1.7.49 | None |
| `getgrav/grav` | Packagist | All versions to 1.7.49 | None |

Products: Getgrav Grav.

## How do I fix CVE-2025-65186?

No fix has been published for CVE-2025-65186 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-65186 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65186 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65186 and fix it if it is affected.

What it is: CVE-2025-65186 is a medium-severity cross-site scripting vulnerability in Getgrav Grav, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65186 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions up to 1.7.49; no fix listed
- getgrav/grav (Packagist): affected all versions up to 1.7.49; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65186/ (Markdown: https://insights.sbomify.com/CVE-2025-65186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65186
- OSV: https://osv.dev/vulnerability/CVE-2025-65186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65186/
Summaries are generated and may contain mistakes; the official description above is the record.
