# CVE-2025-65430: django-allauth does not reject access tokens for inactive users

> Attackers can retain access using previously issued tokens even after an account is deactivated, bypassing intended authentication controls.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2025
- **Updated:** 15 Dec 2025
- **Also known as:** DEBIAN-CVE-2025-65430, GHSA-qhmc-3mvr-f2j4, PYSEC-2025-110, UBUNTU-CVE-2025-65430

## What is CVE-2025-65430?

CVE-2025-65430 is a medium-severity authentication bypass vulnerability in n/a, published on 15 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in allauth-django before 65.13.0. IdP: marking a user as is_active=False after having handed tokens for that user while the account was still active had no effect. Fixed the access/refresh tokens are now rejected.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-65430?

3 open source packages ship an affected version, including django-allauth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-allauth` | PyPI | All versions | 65.13.0 |
| `django-allauth` | PyPI | All versions | 65.13.0 |
| `django-allauth` | PyPI | All versions | 65.13.0 |

Products: Allauth Allauth.

## How do I fix CVE-2025-65430?

Upgrade django-allauth to 65.13.0 or later.

## Is CVE-2025-65430 being exploited?

There is no known exploitation of CVE-2025-65430 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-65431](https://insights.sbomify.com/CVE-2025-65431/): django-allauth's Okta and NetIQ implementations used a mutable identifier for authorization decisions (medium 5.4)
- [CVE-2026-27982](https://insights.sbomify.com/CVE-2026-27982/): django-allauth has an open redirect vulnerability (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65430 and fix it if it is affected.

What it is: CVE-2025-65430 is a medium-severity authentication bypass vulnerability in n/a, published on 15 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-65430 in the wild and no public exploit code.

Affected packages and fixed versions:
- django-allauth (PyPI): affected all versions; fixed in 65.13.0
- django-allauth (PyPI): affected all versions; fixed in 65.13.0
- django-allauth (PyPI): affected all versions; fixed in 65.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65430/ (Markdown: https://insights.sbomify.com/CVE-2025-65430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65430
- OSV: https://osv.dev/vulnerability/CVE-2025-65430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65430/
Summaries are generated and may contain mistakes; the official description above is the record.
