# CVE-2025-6545: pbkdf2 returns predictable uninitialized/zero-filled memory for non-normalized or unimplemented algos

> The pbkdf2 library returns predictable zero-filled memory for unsupported algorithms, enabling signature spoofing in Node.js applications.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2025
- **Updated:** 23 Jun 2025
- **Also known as:** DEBIAN-CVE-2025-6545, GHSA-h7cp-r72f-jxh6, ROOT-APP-NPM-CVE-2025-6545, UBUNTU-CVE-2025-6545, USN-8452-1

## What is CVE-2025-6545?

CVE-2025-6545 is a critical vulnerability in pbkdf2, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in pbkdf2 allows Signature Spoofing by Improper Validation. This vulnerability is associated with program files lib/to-buffer.Js.

This issue affects pbkdf2: from 3.0.10 through 3.1.2.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-6545?

2 open source packages ship an affected version, including pbkdf2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pbkdf2` | npm | From 3.0.10 | 3.1.3 |
| `pbkdf2` | npm | From 3.0.10 | 3.1.3 |

## How do I fix CVE-2025-6545?

Upgrade pbkdf2 to 3.1.3 or later.

## Is CVE-2025-6545 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6545 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6545 and fix it if it is affected.

What it is: CVE-2025-6545 is a critical vulnerability in pbkdf2, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6545 exists.

Affected packages and fixed versions:
- pbkdf2 (npm): affected from 3.0.10; fixed in 3.1.3
- pbkdf2 (npm): affected from 3.0.10; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6545/ (Markdown: https://insights.sbomify.com/CVE-2025-6545/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6545
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6545
- OSV: https://osv.dev/vulnerability/CVE-2025-6545

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6545/
Summaries are generated and may contain mistakes; the official description above is the record.
