# CVE-2025-65465: A reflected Cross-Site Scripting (XSS) vulnerability in the RaiseError function of Skrol29 TbsZip version 2.17 and earlier allows remote att


- **Severity:** Medium 6.1 (`CVSS:3.1/AC:L/AV:N/A:N/C:L/I:L/PR:N/S:C/UI:R`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 2 Mar 2026
- **Updated:** 2 Mar 2026
- **Also known as:** GHSA-2p3c-9cpr-r34w

## What is CVE-2025-65465?

CVE-2025-65465 is a medium-severity vulnerability in n/a, published on 2 Mar 2026. 

### Official description

A reflected Cross-Site Scripting (XSS) vulnerability in the RaiseError function of Skrol29 TbsZip version 2.17 and earlier allows remote attackers to execute arbitrary web script or HTML via a crafted payload in a filename parameter (e.g., to the FileRead function). This occurs because the error message is not properly sanitized before being output to the user. This vulnerability is fixed in version 2.18.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-65465?


## How do I fix CVE-2025-65465?

No fix has been published for CVE-2025-65465 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-65465 being exploited?

There is no known exploitation of CVE-2025-65465 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65465 and fix it if it is affected.

What it is: CVE-2025-65465 is a medium-severity vulnerability in n/a, published on 2 Mar 2026. 
Exploitation: There is no known exploitation of CVE-2025-65465 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65465/ (Markdown: https://insights.sbomify.com/CVE-2025-65465/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65465
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65465
- OSV: https://osv.dev/vulnerability/CVE-2025-65465

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65465/
Summaries are generated and may contain mistakes; the official description above is the record.
