CVE-2025-6547 On Node.js < 3, pbkdf2 silently disregards Uint8Array input, returning static keys
The pbkdf2 library ignores Uint8Array inputs, generating static keys that allow attackers to bypass signature validation mechanisms.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6547?
CVE-2025-6547 is a critical vulnerability in pbkdf2, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Input Validation vulnerability in pbkdf2 allows Signature Spoofing by Improper Validation.This issue affects pbkdf2: <=3.1.2.
Weakness: CWE-20
Which versions are affected by CVE-2025-6547?
2 open source packages ship an affected version, including pbkdf2.
| Package | Affected | Fixed in |
|---|---|---|
pbkdf2 npm | From 1.0.0 | 3.1.3 |
pbkdf2 npm | From 1.0.0 | 3.1.3 |
How do I fix CVE-2025-6547?
Upgrade pbkdf2 to 3.1.3 or later.
Is CVE-2025-6547 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6547 exists.
Sources
Also known as GHSA-v62p-rq8g-8h59, ROOT-APP-NPM-CVE-2025-6547.