# CVE-2025-65482: XDocReport affected by an XML External Entity (XXE) vulnerability

> Attackers can execute arbitrary code by uploading a crafted .docx file to applications using the XDocReport library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2026
- **Updated:** 21 Jan 2026
- **Also known as:** GHSA-7jc7-g598-2p64

## What is CVE-2025-65482?

CVE-2025-65482 is a critical vulnerability in n/a, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An XML External Entity (XXE) vulnerability in opensagres XDocReport v0.9.2 to v2.0.3 allows attackers to execute arbitrary code via uploading a crafted .docx file.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-65482?

2 open source packages ship an affected version, including fr.opensagres.xdocreport:fr.opensagres.xdocreport.document. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fr.opensagres.xdocreport:fr.opensagres.xdocreport.document` | Maven | From 0.9.2 | 2.0.4 |
| `fr.opensagres.xdocreport:fr.opensagres.xdocreport.document` | Maven | From 0.9.2 | 2.0.4 |

Products: Opensagres Xdocreport.

## How do I fix CVE-2025-65482?

Upgrade fr.opensagres.xdocreport:fr.opensagres.xdocreport.document to 2.0.4 or later.

## Is CVE-2025-65482 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65482 exists.

Public exploit code:

- CVE-2025-65482 (XXE) (github_poc): https://github.com/AT190510-Cuong/CVE-2025-65482-XXE-

## Other vulnerabilities in n/a

- [CVE-2025-64087](https://insights.sbomify.com/CVE-2025-64087/): XDocReport affected by a Server-Side Template Injection (SSTI) vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65482 and fix it if it is affected.

What it is: CVE-2025-65482 is a critical vulnerability in n/a, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-65482 exists.

Affected packages and fixed versions:
- fr.opensagres.xdocreport:fr.opensagres.xdocreport.document (Maven): affected from 0.9.2; fixed in 2.0.4
- fr.opensagres.xdocreport:fr.opensagres.xdocreport.document (Maven): affected from 0.9.2; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65482/ (Markdown: https://insights.sbomify.com/CVE-2025-65482/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65482
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65482
- OSV: https://osv.dev/vulnerability/CVE-2025-65482

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65482/
Summaries are generated and may contain mistakes; the official description above is the record.
