# CVE-2025-65516: Cross-site scripting in n/a

> Attackers can execute arbitrary JavaScript in victims' browsers via crafted SVG files when the Golang file server is enabled.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 4 Dec 2025
- **Updated:** 5 Dec 2025
- **Also known as:** GHSA-86jv-vvjm-w37g

## What is CVE-2025-65516?

CVE-2025-65516 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A stored cross-site scripting (XSS) vulnerability was discovered in Seafile Community Edition prior to version 13.0.12. When Seafile is configured with the Golang file server, an attacker can upload a crafted SVG file containing malicious JavaScript and share it using a public link. Opening the link triggers script execution in the victim's browser. This issue has been fixed in Seafile Community Edition 13.0.12.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-65516?

It affects 1 product.


Products: Seafile Seafile Server.

## How do I fix CVE-2025-65516?

No fix has been published for CVE-2025-65516 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-65516 being exploited?

There is no known exploitation of CVE-2025-65516 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-5443](https://insights.sbomify.com/CVE-2014-5443/): Privilege escalation in n/a (high 7.8)
- [CVE-2021-43820](https://insights.sbomify.com/CVE-2021-43820/): Permissions check bypass in Seafile (high 7.4)
- [CVE-2026-30587](https://insights.sbomify.com/CVE-2026-30587/): Seafile Server has multiple stored XSS vulnerabilities (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-65516 and fix it if it is affected.

What it is: CVE-2025-65516 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-65516 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-65516/ (Markdown: https://insights.sbomify.com/CVE-2025-65516/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-65516
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-65516
- OSV: https://osv.dev/vulnerability/CVE-2025-65516

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-65516/
Summaries are generated and may contain mistakes; the official description above is the record.
